aboutsummaryrefslogtreecommitdiffstats
path: root/math/saga/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/saga/Makefile')
-rw-r--r--math/saga/Makefile65
1 files changed, 30 insertions, 35 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 3b256ad687cd..0467e8da60f8 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 2.1.2
-PORTREVISION= 6
+PORTVERSION= 2.1.4
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -14,27 +13,26 @@ COMMENT= System for Automated Geoscientific Analyses
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20
+BUILD_DEPENDS= swig3.0:${PORTSDIR}/devel/swig30
LIB_DEPENDS= libproj.so:${PORTSDIR}/graphics/proj \
libgdal.so:${PORTSDIR}/graphics/gdal \
libhpdf.so:${PORTSDIR}/print/libharu \
libjasper.so:${PORTSDIR}/graphics/jasper \
libtiff.so:${PORTSDIR}/graphics/tiff \
libodbc.so:${PORTSDIR}/databases/unixODBC \
- liblas.so:${PORTSDIR}/devel/liblas \
+ liblas.so:${PORTSDIR}/devel/liblas12 \
libopencv_ml.so:${PORTSDIR}/graphics/opencv
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFIGURE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
--enable-python
-CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig2.0"
+CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib -lopencv_contrib
-# Python no option any more, because it can't be turned off completely
USE_LDCONFIG= yes
USE_WX= 3.0+
-USES= compiler:gcc-c++11-lib iconv:wchar_t dos2unix libtool python:2
+USES= autoreconf compiler:gcc-c++11-lib iconv:wchar_t dos2unix libtool python:2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WX_UNICODE= yes
@@ -60,28 +58,28 @@ VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:${PORTSDIR}/graphics/vigra
.include <bsd.port.pre.mk>
+post-extract:
+ @${REINPLACE_CMD} -e 's|wx-config |${WX_CONFIG} |g' \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/src/saga_core/saga_api/Makefile.am \
+ ${WRKSRC}/src/saga_core/saga_cmd/Makefile.am \
+ ${WRKSRC}/src/saga_core/saga_gdi/Makefile.am \
+ ${WRKSRC}/src/saga_core/saga_gui/Makefile.am \
+ ${WRKSRC}/src/modules/garden/garden_3d_viewer/Makefile.am \
+ ${WRKSRC}/src/modules/garden/garden_webservices/Makefile.am \
+ ${WRKSRC}/src/modules/io/io_grid_image/Makefile.am \
+ ${WRKSRC}/src/modules/io/io_shapes/Makefile.am \
+ ${WRKSRC}/src/modules/pointcloud/pointcloud_tools/Makefile.am \
+ ${WRKSRC}/src/modules/pointcloud/pointcloud_viewer/Makefile.am \
+ ${WRKSRC}/src/modules/tin/tin_viewer/Makefile.am \
+ ${WRKSRC}/src/modules/statistics/statistics_kriging/Makefile.am
+
post-patch:
- @${REINPLACE_CMD} -e's|wx-config |${WX_CONFIG} |g' \
- ${WRKSRC}/configure \
- ${WRKSRC}/src/saga_core/saga_gui/Makefile.in \
- ${WRKSRC}/src/saga_core/saga_api/Makefile.in \
- ${WRKSRC}/src/saga_core/saga_cmd/Makefile.in \
- ${WRKSRC}/src/saga_core/saga_gdi/Makefile.in \
- ${WRKSRC}/src/modules/garden/garden_webservices/Makefile.in \
- ${WRKSRC}/src/modules/garden/garden_3d_viewer/Makefile.in \
- ${WRKSRC}/src/modules/io/io_shapes/Makefile.in \
- ${WRKSRC}/src/modules/io/io_grid_image/Makefile.in \
- ${WRKSRC}/src/modules/pointcloud/pointcloud_tools/Makefile.in \
- ${WRKSRC}/src/modules/pointcloud/pointcloud_viewer/Makefile.in \
- ${WRKSRC}/src/modules/tin/tin_viewer/Makefile.in \
- ${WRKSRC}/src/modules/statistics/statistics_kriging/Makefile.in
@${REINPLACE_CMD} -e 's|-lcv|-lopencv_core -lopencv_imgproc|g' \
- ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile.in
- @${REINPLACE_CMD} -e 's|lib_cv|lib_opencv_core|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lcv |-lopencv_core |' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|\\n"), SAGA_VERSION)| (rev. 2121)\\n"), SAGA_VERSION)|' \
+ ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile.am
+ @${REINPLACE_CMD} -e 's|\[cv\]|\[opencv_core\]|' \
+ ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e 's|wxString(SAGA_VERSION) + "\\n"|wxString(SAGA_VERSION) + " (SVN r2316)" + "\\n"|' \
${WRKSRC}/src/saga_core/saga_gui/dlg_about.cpp
.if ${ARCH} == "powerpc"
@${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
@@ -91,13 +89,9 @@ post-patch:
post-configure:
@${REINPLACE_CMD} -e 's|cd $$(pkgdatadir);|cd ${STAGEDIR}${DATADIR};|g' \
${WRKSRC}/src/saga_core/saga_gui/Makefile
- @${REINPLACE_CMD} -e 's|mv saga_srs.txt saga_prj.srs|mv \
- ${STAGEDIR}${DATADIR}/saga_srs.txt \
- ${STAGEDIR}${DATADIR}/saga_prj.srs|g' \
+ @${REINPLACE_CMD} -e 's|mv saga_srs.txt saga_prj.srs|mv ${STAGEDIR}${DATADIR}/saga_srs.txt ${STAGEDIR}${DATADIR}/saga_prj.srs|g' \
${WRKSRC}/src/saga_core/saga_gui/Makefile
- @${REINPLACE_CMD} -e 's|mv saga_dic.txt saga_prj.dic|mv \
- ${STAGEDIR}${DATADIR}/saga_dic.txt \
- ${STAGEDIR}${DATADIR}/saga_prj.dic|g' \
+ @${REINPLACE_CMD} -e 's|mv saga_dic.txt saga_prj.dic|mv ${STAGEDIR}${DATADIR}/saga_dic.txt ${STAGEDIR}${DATADIR}/saga_prj.dic|g' \
${WRKSRC}/src/saga_core/saga_gui/Makefile
post-install:
@@ -106,11 +100,12 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.lng.txt ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.ger.txt ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.png ${STAGEDIR}${DATADIR}
+ ${CHMOD} -R a+rw ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications/
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsaga_api-${PORTVERSION}.so
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_saga_api-${PORTVERSION}.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsaga_gdi-${PORTVERSION}.so
- ${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.desktop \
- ${STAGEDIR}${PREFIX}/share/applications/
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/saga/*.so
# library helper files are not needed and cripple some math/qgis extensions
@${RM} ${STAGEDIR}${PREFIX}/lib/saga/*.la