aboutsummaryrefslogtreecommitdiffstats
path: root/math/scilab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/scilab/Makefile')
-rw-r--r--math/scilab/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index d7c890449cec..186cf453440f 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -84,7 +84,10 @@ MAKE_ENV+= BLAS_LIBS="-L${LOCALBASE}/lib ${BLAS_LIBS}"
# Scilab broken with GCC 3.3 on FreeBSD 5.3
.if ${OSVERSION} >= 503000 && ${OSVERSION} < 600000
-USE_GCC= 3.2
+#USE_GCC= 3.2 #override FC and F77
+BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
+CC= gcc32
+CXX= g++32
.endif
WANT_FORTRAN=yes #dummy but future use