aboutsummaryrefslogtreecommitdiffstats
path: root/math/superlu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/superlu/Makefile')
-rw-r--r--math/superlu/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index d201105956db..ab77e2b44f8e 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -23,23 +23,23 @@ COMMENT= A library of routines for performing sparse factorization
.include <bsd.port.pre.mk>
-USE_BLAS?= reference
-
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS= -lblas
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
+BLAS= -lptf77blas
.endif
USE_FORTRAN= yes