aboutsummaryrefslogtreecommitdiffstats
path: root/math/superlu
diff options
context:
space:
mode:
Diffstat (limited to 'math/superlu')
-rw-r--r--math/superlu/Makefile7
-rw-r--r--math/superlu/files/patch-make.inc24
-rw-r--r--math/superlu/pkg-plist2
3 files changed, 22 insertions, 11 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index ab77e2b44f8e..17cee82d2ddd 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= superlu
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSION= ${P_VERSION}.20060201
CATEGORIES= math
MASTER_SITES= http://crd.lbl.gov/~xiaoye/SuperLU/ \
@@ -43,6 +43,7 @@ BLAS= -lptf77blas
.endif
USE_FORTRAN= yes
+USE_LDCONFIG= yes
P_VERSION= 3.0
WRKSRC= ${WRKDIR}/SuperLU_${P_VERSION}
@@ -65,6 +66,10 @@ pre-build:
do-install:
${INSTALL_DATA} ${WRKSRC}/libsuperlu_${P_VERSION}.a \
${PREFIX}/lib/libsuperlu.a
+ ${INSTALL_DATA} ${WRKSRC}/libsuperlu_${P_VERSION}.so \
+ ${PREFIX}/lib/libsuperlu.so.${PORTREVISION}
+ ${LN} -s ${PREFIX}/lib/libsuperlu.so.${PORTREVISION} \
+ ${PREFIX}/lib/libsuperlu.so
@${MKDIR} ${PREFIX}/include/superlu
${INSTALL_DATA} ${WRKSRC}/SRC/*.h ${PREFIX}/include/superlu
.if !defined(NOPORTDOCS)
diff --git a/math/superlu/files/patch-make.inc b/math/superlu/files/patch-make.inc
index d59436f52450..18ab9f7ccda6 100644
--- a/math/superlu/files/patch-make.inc
+++ b/math/superlu/files/patch-make.inc
@@ -1,15 +1,19 @@
---- make.inc.orig 2006-01-01 18:52:00.000000000 -0500
-+++ make.inc 2008-06-19 22:08:49.000000000 -0500
-@@ -19,7 +19,7 @@
+--- make.inc.orig 2006-01-02 00:52:00.000000000 +0100
++++ make.inc 2012-03-13 14:59:15.000000000 +0100
+@@ -19,22 +19,23 @@
#
TMGLIB = libtmglib.a
SUPERLULIB = libsuperlu_3.0.a
-BLASLIB = ../libblas.a
-+BLASLIB = %%BLAS%%
++SUPERLULIB_SHARED = libsuperlu_3.0.so
++BLASLIB = -L/usr/local/lib -lblas
#
# The archiver and the flag(s) to use when building archive (library)
-@@ -29,12 +29,12 @@
+ # If your system has no ranlib, set RANLIB = echo.
+ #
+-ARCH = ar
++ARCMD = ar
ARCHFLAGS = cr
RANLIB = ranlib
@@ -19,11 +23,11 @@
-FFLAGS = -O
-LOADER = cc
-LOADOPTS = -xO3
-+CC = %%CC%%
-+CFLAGS = %%CFLAGS%%
-+FORTRAN = %%FC%%
-+FFLAGS = %%FFLAGS%%
-+LOADER = %%FC%%
++CC ?= gcc46
++CFLAGS ?= -O2 -pipe -O2 -fno-strict-aliasing -pipe -O3 -pipe -fno-strict-aliasing -march=native -Wl,-rpath=/usr/local/lib/gcc46
++FORTRAN ?= gfortran46
++FFLAGS ?= -O -Wl,-rpath=/usr/local/lib/gcc46
++LOADER ?= gfortran46
+LOADOPTS =
#
diff --git a/math/superlu/pkg-plist b/math/superlu/pkg-plist
index e472b72cfc70..20efa11a516f 100644
--- a/math/superlu/pkg-plist
+++ b/math/superlu/pkg-plist
@@ -10,6 +10,8 @@ include/superlu/slu_util.h
include/superlu/slu_zdefs.h
include/superlu/supermatrix.h
lib/libsuperlu.a
+lib/libsuperlu.so
+lib/libsuperlu.so.3
@dirrm include/superlu
%%PORTDOCS%%%%DOCSDIR%%/SLU_general.ps.gz
%%PORTDOCS%%%%DOCSDIR%%/simax95.ps.gz