aboutsummaryrefslogtreecommitdiffstats
path: root/math/unixstat
diff options
context:
space:
mode:
Diffstat (limited to 'math/unixstat')
-rw-r--r--math/unixstat/Makefile53
-rw-r--r--math/unixstat/distinfo2
-rw-r--r--math/unixstat/files/patch-Makefile20
-rw-r--r--math/unixstat/files/patch-src82
-rw-r--r--math/unixstat/pkg-descr16
-rw-r--r--math/unixstat/pkg-plist59
6 files changed, 0 insertions, 232 deletions
diff --git a/math/unixstat/Makefile b/math/unixstat/Makefile
deleted file mode 100644
index b24b58be9b30..000000000000
--- a/math/unixstat/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# Created by: mwm
-# $FreeBSD$
-
-PORTNAME= unixstat
-PORTVERSION= 5.4
-PORTREVISION= 1
-CATEGORIES= math
-MASTER_SITES= # must fetch manually
-DISTNAME= stat
-EXTRACT_SUFX= .tar.Z
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Statistics package designed for use with the Unix shell
-
-RESTRICTED= License does not allow mass redistribution.
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-EXTRACT_CMD= uncompress
-EXTRACT_BEFORE_ARGS=-c
-EXTRACT_AFTER_ARGS=| ${TAR} -xf -
-
-MAN1= abut.1 anova.1 calc.1 colex.1 contab.1 desc.1 dm.1 dprime.1 \
- dsort.1 features.1 ff.1 fls.1 fpack.1 linex.1 maketrix.1 \
- manstat.1 oneway.1 pair.1 perm.1 probdist.1 rankind.1 \
- rankrel.1 ranksort.1 regress.1 repeat.1 reverse.1 series.1 \
- stats.1 transpose.1 ts.1 unixstat.1 validata.1
-
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= Gary Perlman requires that users agree to his license\
-before he will allow access to the distfile.\
-See his web site at http://www.acm.org/~perlman/stat/ for\
-details. Then put ${DISTNAME}${EXTRACT_SUFX} in\
-${DISTDIR} and run make again
-.endif
-
-post-patch:
- @${MV} ${WRKSRC}/man/intro.1 ${WRKSRC}/man/unixstat.1
- @${RM} ${WRKSRC}/man/cat.1
-
-do-build:
- @(cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} make ${MAKE_ARGS})
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/man/*.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/handbook/* ${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/math/unixstat/distinfo b/math/unixstat/distinfo
deleted file mode 100644
index 0d1e4cf70528..000000000000
--- a/math/unixstat/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (stat.tar.Z) = 1ea41c4a7350c7bdb50ca7529c2d44819a2b2d73b74c2a98e636829f2964dd34
-SIZE (stat.tar.Z) = 591053
diff --git a/math/unixstat/files/patch-Makefile b/math/unixstat/files/patch-Makefile
deleted file mode 100644
index 9d621641d9b6..000000000000
--- a/math/unixstat/files/patch-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/makefile.orig Tue Jun 22 18:00:21 1993
-+++ src/makefile Sun Dec 12 22:51:48 2004
-@@ -14,14 +14,13 @@
- ##########################################################################
-
- DESTDIR=../bin# destination directory
--DESTDIR=../../bin# destination directory
--CFLAGS =-O# C Compiler Options
-+#DESTDIR=../../bin# destination directory
- LINK =$(CC) $(CFLAGS) -o $(DESTDIR)/$@# Generic link command
- LIBS =-lm# libraries needed (math)
--EDITOR =/usr/ucb/vi# editor to call on make edit
-+EDITOR =/usr/bin/vi# editor to call on make edit
- RM =/bin/rm -f# remove forcefully
- MV =/bin/mv# move/rename files
--MAKE =/bin/make# use for recursive makes
-+MAKE =/usr/bin/make# use for recursive makes
-
- MAINS = abut.c anova.c calc.y colex.c contab.c desc.c dm.y dprime.c \
- dsort.c features.c ff.c fpack.c linex.c maketrix.c oneway.c \
diff --git a/math/unixstat/files/patch-src b/math/unixstat/files/patch-src
deleted file mode 100644
index 3aa26aabaf0b..000000000000
--- a/math/unixstat/files/patch-src
+++ /dev/null
@@ -1,82 +0,0 @@
---- src/ff.c.orig Sun Dec 12 22:56:48 2004
-+++ src/ff.c Sun Dec 12 22:59:17 2004
-@@ -911,7 +911,7 @@
-
- strcpy (numbuf, oldexpand (title, gpage, page, file));
- if (Needfls)
-- fls (file, numbuf, answer);
-+ usfls (file, numbuf, answer);
- else
- strcpy (answer, numbuf);
- return (answer);
---- src/fls.c.orig Sun Dec 12 22:59:31 2004
-+++ src/fls.c Sun Dec 12 23:00:12 2004
-@@ -183,7 +183,7 @@
- statstdin (statptr)
- struct stat *statptr;
- {
-- long clock, time ();
-+ long clock ;
- clock = time (0);
- statptr->st_atime = clock;
- statptr->st_mtime = clock;
-@@ -200,7 +200,7 @@
-
- /*FUNCTION fls: formated listing of file */
- Status
--fls (file, format, bptr) /* put formatted file listing in buffer */
-+usfls (file, format, bptr) /* put formatted file listing in buffer */
- char *file; /* name of the file to print */
- char *format; /* print format control string, like printf */
- char *bptr; /* pointer to buffer in which to print stats */
---- src/calc.c.orig Sun Dec 12 23:08:23 2004
-+++ src/calc.c Sun Dec 12 23:11:21 2004
-@@ -1,4 +1,3 @@
--extern char *malloc(), *realloc();
-
- # line 2 "calc.y"
- /* Copyright 1981 Gary Perlman */
-@@ -79,7 +78,7 @@
- double eval (), Answer;
- double *Constant;
- char *getline ();
--FILE *Outfile = stdout;
-+FILE *Outfile;
-
- # line 83 "calc.y"
- typedef union
-@@ -222,6 +221,7 @@
- {
- int i;
- signal (SIGINT, SIG_IGN);
-+ Outfile = stdout;
- if (isatty (fileno (stdin)))
- {
- Interactive = 1;
-*** /tmp/perm.c.orig Sat Jul 14 18:22:36 2007
---- src/perm.c Sat Jul 14 18:23:06 2007
-***************
-*** 19,29 ****
- Boole InfoLimits; /* print program limits */
- Boole InfoOptions; /* print usage information */
-
-! int jpossible Cdecl ((char **array, int n, int * choice, int i));
-! int jgetunused Cdecl ((char **array, int n, int i));
-! int jchoose Cdecl ((char **array, int n, int *choice, int i));
- Status jstrpermut Cdecl ((char **array, int n));
-! void jprint Cdecl ((char *name, char **array, int n));
- void strpermut Cdecl ((char **array, int size));
- int initial Cdecl ((int argc, char **argv));
- void usinfo Cdecl ((void));
---- 19,29 ----
- Boole InfoLimits; /* print program limits */
- Boole InfoOptions; /* print usage information */
-
-! static int jpossible Cdecl ((char **array, int n, int * choice, int i));
-! static int jgetunused Cdecl ((char **array, int n, int i));
-! static int jchoose Cdecl ((char **array, int n, int *choice, int i));
- Status jstrpermut Cdecl ((char **array, int n));
-! static void jprint Cdecl ((char *name, char **array, int n));
- void strpermut Cdecl ((char **array, int size));
- int initial Cdecl ((int argc, char **argv));
- void usinfo Cdecl ((void));
diff --git a/math/unixstat/pkg-descr b/math/unixstat/pkg-descr
deleted file mode 100644
index 8ba48e2ff4f5..000000000000
--- a/math/unixstat/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-|STAT is a set of about 30 data manipulation and analysis programs
-developed by Gary Perlman at the University of California, San Diego
-and at the Wang Institute. The manipulation programs are general
-utilities that work with other standard programs like sort. The
-analysis programs compute most widely used statistics. |STAT programs
-are designed with the philosophy that individual programs should be
-designed as tools that do one task well and produce output suitable
-for input via pipes to |STAT and other programs. Interactive use is
-supported in the command line interpreter/editor while batch files or
-shell scripts provide a programming language for complex
-analyses. Typical usage involves a pipeline of transformations of data
-followed by input to an analysis program, summarized schematically by:
-
- INPUT DATA | TRANSFORM | ANALYSIS | OUTPUT RESULTS
-
-WWW: http://www.acm.org/~perlman/stat/
diff --git a/math/unixstat/pkg-plist b/math/unixstat/pkg-plist
deleted file mode 100644
index eb94330155a4..000000000000
--- a/math/unixstat/pkg-plist
+++ /dev/null
@@ -1,59 +0,0 @@
-bin/abut
-bin/anova
-bin/calc
-bin/colex
-bin/contab
-bin/desc
-bin/dm
-bin/dprime
-bin/dsort
-bin/features
-bin/ff
-bin/fpack
-bin/linex
-bin/maketrix
-bin/oneway
-bin/pair
-bin/perm
-bin/probdist
-bin/rankind
-bin/rankrel
-bin/ranksort
-bin/regress
-bin/repeat
-bin/reverse
-bin/series
-bin/stats
-bin/transpose
-bin/ts
-bin/validata
-%%PORTDOCS%%%%DOCSDIR%%/!Cover.nr
-%%PORTDOCS%%%%DOCSDIR%%/!Cover.ps
-%%PORTDOCS%%%%DOCSDIR%%/!Cover.txt
-%%PORTDOCS%%%%DOCSDIR%%/0-Preface.nr
-%%PORTDOCS%%%%DOCSDIR%%/0-Preface.ps
-%%PORTDOCS%%%%DOCSDIR%%/1-Introduction.nr
-%%PORTDOCS%%%%DOCSDIR%%/1-Introduction.ps
-%%PORTDOCS%%%%DOCSDIR%%/2-Example.nr
-%%PORTDOCS%%%%DOCSDIR%%/2-Example.ps
-%%PORTDOCS%%%%DOCSDIR%%/3-Conventions.nr
-%%PORTDOCS%%%%DOCSDIR%%/3-Conventions.ps
-%%PORTDOCS%%%%DOCSDIR%%/4-Manipulation.nr
-%%PORTDOCS%%%%DOCSDIR%%/4-Manipulation.ps
-%%PORTDOCS%%%%DOCSDIR%%/5-Analysis.nr
-%%PORTDOCS%%%%DOCSDIR%%/5-Analysis.ps
-%%PORTDOCS%%%%DOCSDIR%%/6-Manuals.nr
-%%PORTDOCS%%%%DOCSDIR%%/6-Manuals.ps
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/Calc.nr
-%%PORTDOCS%%%%DOCSDIR%%/DM.nr
-%%PORTDOCS%%%%DOCSDIR%%/contents.nr
-%%PORTDOCS%%%%DOCSDIR%%/exam.dat
-%%PORTDOCS%%%%DOCSDIR%%/example.bat
-%%PORTDOCS%%%%DOCSDIR%%/example.txt
-%%PORTDOCS%%%%DOCSDIR%%/handbook.txt
-%%PORTDOCS%%%%DOCSDIR%%/macros
-%%PORTDOCS%%%%DOCSDIR%%/macros.txt
-%%PORTDOCS%%%%DOCSDIR%%/makefile
-%%PORTDOCS%%%%DOCSDIR%%/update.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%