aboutsummaryrefslogtreecommitdiffstats
path: root/math/xgfe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/xgfe/Makefile')
-rw-r--r--math/xgfe/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/xgfe/Makefile b/math/xgfe/Makefile
new file mode 100644
index 000000000000..abcc86355eed
--- /dev/null
+++ b/math/xgfe/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xgfe
+# Version required: 1.2
+# Date created: 24 March 1998
+# Whom: Matthew Hunt <mph@pobox.com>
+#
+# $Id$
+#
+
+DISTNAME= xgfe-1.2
+CATEGORIES= math
+MASTER_SITES= http://www2.msstate.edu/~dmi1/xgfe/download/
+
+MAINTAINER= mph@pobox.com
+
+LIB_DEPENDS= qt\\.1\\.3:${PORTSDIR}/x11/qt
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+
+USE_X11= yes
+
+MAKE_ENV= X11BASE=$(X11BASE) PREFIX=$(PREFIX)
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=$(NOPORTDOCS)
+.endif
+
+WRKSRC= $(WRKDIR)/$(DISTNAME)/source
+
+post-extract:
+ cd $(WRKSRC) && ${RM} Makefile && ${LN} -s Makefile.freebsd.gcc Makefile
+
+.include <bsd.port.mk>