aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/spooles/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/math/spooles/Makefile b/math/spooles/Makefile
index 541c7de36833..646dc484a37b 100644
--- a/math/spooles/Makefile
+++ b/math/spooles/Makefile
@@ -67,9 +67,7 @@ post-patch:
do-build:
.if defined(WITH_MPI)
- @(cd ${WRKSRC}/MPI; ${SETENV} ${MAKE_ENV} ${GMAKE} global -f makefile)
- @(cd ${WRKSRC}/MPI/src; ${SETENV} ${MAKE_ENV} ${GMAKE} )
- @(cd ${WRKSRC}_SHARED/MPI/src; ${SETENV} ${MAKE_ENV} ${GMAKE} global -f makefile)
+ @(cd ${WRKSRC}/MPI/src ; ${SETENV} ${MAKE_ENV} ${GMAKE} -f makeGlobalLib)
@(cd ${WRKSRC}_SHARED/MPI/src; ${SETENV} ${MAKE_ENV} ${GMAKE} -f makeGlobalLib)
@(cd ${WRKSRC}_SHARED ; ld -Bshareable -o libspooles.so.1 -x -soname libspooles.so.1 --whole-archive spooles.a )