aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/taucs/Makefile68
1 files changed, 42 insertions, 26 deletions
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index dcf5170f9b76..cba0ab59a340 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= taucs
PORTVERSION= 2.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math
MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/
DISTNAME= ${PORTNAME}
@@ -16,57 +16,74 @@ EXTRACT_SUFX= .tgz
MAINTAINER= bf@FreeBSD.org
COMMENT= C library of sparse linear solvers
+LIB_DEPENDS= metis.1:${PORTSDIR}/math/metis
+
+HAS_CONFIGURE= yes
USE_FORTRAN= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
.include <bsd.port.pre.mk>
-LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+.if exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-.if defined(WITH_ATLAS)
+
+.if ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -lcblas -latlas
-LAPACK= -lalapack
-.else
+BLAS= -lf77blas
+LAPACK= -lalapack -lcblas
+.elif ${WITH_BLAS} == reference
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS= -lblas
LAPACK= -llapack
.endif
-HAS_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKEFILE= makefile
-ALL_TARGET=
-
.if ${ARCH} == "sparc64"
PICFLAG?= -fPIC
-BROKEN= Does not link on sparc64
.else
PICFLAG?= -fpic
.endif
do-extract:
- ${MKDIR} ${WRKSRC} ; cd ${WRKSRC} ; ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${EXTRACT_AFTER_ARGS}
+ @${MKDIR} ${WRKSRC}; cd ${WRKSRC}; ${EXTRACT_CMD} \
+ ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ ${EXTRACT_AFTER_ARGS}
post-patch:
- @${MKDIR} ${WRKSRC}_SHARED ; ${CP} -r ${WRKSRC}/* ${WRKSRC}_SHARED
+ @${CP} -r ${WRKSRC} ${WRKSRC}_SHARED
do-configure:
- cd ${WRKSRC}; ./configure
- cd ${WRKSRC}_SHARED; ./configure
+ @cd ${WRKSRC}; ./configure
+ @cd ${WRKSRC}_SHARED; ./configure
post-configure:
- @(cd ${WRKSRC}; ${PATCH} <${FILESDIR}/extra-patch-build-FreeBSD-makefile)
- @(cd ${WRKSRC}_SHARED; ${PATCH} <${FILESDIR}/extra-patch-build-FreeBSD-makefile)
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' -e 's+%%FC%%+${FC}+g;' -e 's+%%BLAS%%+${BLAS}+g;' -e 's+%%LAPACK%%+${LAPACK}+g;' -e 's+%%CC%%+${CC}+g;' -e 's+%%CFLAGS%%+${CFLAGS}+g;' -e 's+%%FFLAGS%%+${FFLAGS}+g;' ${WRKSRC}/config/FreeBSD.mk
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' -e 's+%%FC%%+${FC}+g;' -e 's+%%BLAS%%+${BLAS}+g;' -e 's+%%LAPACK%%+${LAPACK}+g;' -e 's+%%CC%%+${CC}+g;' -e 's+%%CFLAGS%%+${CFLAGS} ${PICFLAG}+g;' -e 's+%%FFLAGS%%+${FFLAGS} ${PICFLAG}+g;' ${WRKSRC}_SHARED/config/FreeBSD.mk
+ @cd ${WRKSRC}; ${PATCH} <${FILESDIR}/extra-patch-build-FreeBSD-makefile
+ @cd ${WRKSRC}_SHARED; ${PATCH} <${FILESDIR}/extra-patch-build-FreeBSD-makefile
+ @${REINPLACE_CMD} \
+ -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' -e 's+%%FC%%+${FC}+g;' \
+ -e 's+%%BLAS%%+${BLAS}+g;' -e 's+%%LAPACK%%+${LAPACK}+g;' \
+ -e 's+%%CC%%+${CC}+g;' -e 's+%%CFLAGS%%+${CFLAGS}+g;' \
+ -e 's+%%FFLAGS%%+${FFLAGS}+g;' \
+ ${WRKSRC}/config/FreeBSD.mk
+ @${REINPLACE_CMD} \
+ -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' -e 's+%%FC%%+${FC}+g;' \
+ -e 's+%%BLAS%%+${BLAS}+g;' -e 's+%%LAPACK%%+${LAPACK}+g;' \
+ -e 's+%%CC%%+${CC}+g;' -e 's+%%CFLAGS%%+${CFLAGS} ${PICFLAG}+g;' \
+ -e 's+%%FFLAGS%%+${FFLAGS} ${PICFLAG}+g;' \
+ ${WRKSRC}_SHARED/config/FreeBSD.mk
do-build:
- cd ${WRKSRC} ; ${MAKE}
- cd ${WRKSRC}_SHARED ; ${SETENV} CFLAGS="${CFLAGS} ${PICFLAG}" ${MAKE}
- cd ${WRKSRC}_SHARED/lib/FreeBSD ; ld -Bshareable -o libtaucs.so.1 -x -soname libtaucs.so.1 --whole-archive libtaucs.a
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS}
+ @cd ${WRKSRC}_SHARED; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS}
+ cd ${WRKSRC}_SHARED/lib/FreeBSD ; ${FC} ${FFLAGS} ${PICFLAG} ${LDFLAGS} \
+ -shared -o libtaucs.so.1 -Wl,-x -Wl,-soname,libtaucs.so.1 -Wl,--whole-archive \
+ libtaucs.a -Wl,--no-whole-archive
+
do-install:
@${INSTALL_DATA} ${WRKSRC}/lib/FreeBSD/libtaucs.a ${PREFIX}/lib
@${INSTALL_DATA} ${WRKSRC}_SHARED/lib/FreeBSD/libtaucs.so.1 ${PREFIX}/lib
@@ -75,7 +92,6 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/src/*.h ${PREFIX}/include
@${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/direct ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/iter ${PREFIX}/bin
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${DOCSDIR}
ou get this from GNOME CVS, use the tag "oaf-stable-0-6") *** If you are using oaf from CVS, you should use the flag *** "--disable-more-warnings" when configure, or it may fail to *** build. - gconf - 0.6 or later. - gnome-vfs - 1.0.0 or later (If you get this from GNOME CVS, use the tag "gnome-vfs-1-0") *** If you are using gnome-vfs from CVS, you should use the flag *** "--disable-more-warnings" when configuring, or it may fail to *** build. - libglade - 0.14 or later - bonobo - 1.0.3 or later *** Note that bonobo must be installed with the same --prefix as *** either gnome-libs or evolution for the Makefiles to work *** properly. - gal (GNOME Application Library) - 0.11.99.2 or later - gtkhtml - later than 0.11.0 Other non-GNOME Dependencies: - Berkeley's libdb - 3.1.17 db3 is available from http://www.sleepycat.com. Make sure to get 3.1.17, it isn't the latest version. COMPILING BERKELEY DB --------------------- If you don't have 3.1.17 installed on your system or Evolution doesn't detect it for some reason, here is a way to get Evolution to link to it without messing up your system installation.   * Get the Sleepycat tarball from:       http://www.sleepycat.com/update/3.1.17/db-3.1.17.tar.gz   * Install the content somewhere _other_ than the evolution source tree.     e.g: NOT evolution/db-3.1.17   * Compile according to instructions, but installing into some custom     prefix, for example:       ../dist/configure --prefix=/home/user/berkeleydb-3.1.17   * Autogen Evolution specifying that it has to look for the DB     library there, for example:       ./autogen.sh --prefix=/opt/gnome       --with-db3-includes=/home/user/berkeleydb-3.1.17/include       --with-db3-libs=/home/user/berkeleydb-3.1.17/lib COMPILING PALM PILOT SUPPORT ---------------------------- If you want support for PalmPilot syncing (currently experimental so please back up your pilot) you will also need to do the following: 1) pilot-link 0.9.5 http://www.pilot-link.org 2) gnome-pilot 0.1.61 http://www.eskil.org/gnome-pilot/ 3) evolution In your evolution source directory do ./autogen.sh --prefix=<evo-prefix> --with-pisock=<pilot-link-prefix> --enable-pilot-conduits=yes make make install SSL SUPPORT ----------- If you want SSL support (and someday S/MIME), you will also need libnspr4 and libnss3 which can be found at http://www.mozilla.org. Once you have libnspr4 and libnss3 (and their respective includes) installed, in your evolution source directory do: ./autogen.sh --prefix=<evo-prefix> --with-nspr-includes=<nspr-includes-prefix> --with-nspr-libs=<nspr-libs-prefix> --with-nss-includes=<nss-includes-prefix> --with-nss-libs=<nss-libs-prefix> You'll need to `cp ~/.mozilla/default/*.db ~/evolution` on you've installed Evolution in order to get a functional SSL-enabled Evolution. SOURCE TREE LAYOUT ------------------ addressbook: the Address Book UI art: graphics used by evolution calendar: the Calendar UI camel: libcamel, a messaging library used by the mailer. Camel is inspired by Sun's JavaMail (http://java.sun.com/products/javamail/) and the IMAPv4 spec (RFC 2060). composer: the message composer UI data: the .desktop file for Evolution default_user: initial Evolution config files for new users devel-docs: entirely inadequate documentation doc: more adequate documentation e-util: utility code used by various parts of Evolution filter: libfilter, a mail filtering library libibex: an indexing library used by the mailer libical: a library for the iCalendar format (RFC 2445-2446) libversit: a library for the vCard (RFC 2425-2426) and vCalendar (http://www.imc.org/pdi/vcal-10.txt) formats mail: the mail display UI shell: the Evolution shell (the main program that launches the other components) tests: some test programs tools: utilities, notably "killev", a script to kill of all of the Evolution components widgets: widgets used by Evolution, including the shortcut bar wombat: Has source code that will load in the addressbook and calendar backend, and will form the server process we'll be using