aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-Base36/Makefile4
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile4
-rw-r--r--math/p5-Math-BigRat/Makefile4
-rw-r--r--math/p5-Math-FixedPrecision/Makefile4
-rw-r--r--math/p5-Math-NumberCruncher/Makefile4
-rw-r--r--math/p5-Math-RandomOrg/Makefile4
-rw-r--r--math/p5-Number-WithError/Makefile4
7 files changed, 9 insertions, 19 deletions
diff --git a/math/p5-Math-Base36/Makefile b/math/p5-Math-Base36/Makefile
index f59928add2b2..f326a8951691 100644
--- a/math/p5-Math-Base36/Makefile
+++ b/math/p5-Math-Base36/Makefile
@@ -8,6 +8,7 @@
PORTNAME= Math-Base36
PORTVERSION= 0.07
PORTEPOCH= 2
+PORTRESIVION= 1
CATEGORIES= math perl5 converters
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,9 +16,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mhsin@mhsin.org
COMMENT= Encoding and decoding of base36 strings
-BUILD_DEPENDS= p5-Math-BigInt>=1.60:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Math::Base36.3
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
index 9085ca0efd0f..4fc10f5b84fe 100644
--- a/math/p5-Math-BigInt-GMP/Makefile
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-BigInt-GMP
PORTVERSION= 1.24
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,8 +16,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Math::BigInt::GMP - Use the GMP library for Math::BigInt routines
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
-BUILD_DEPENDS= p5-Math-BigInt>=1.78:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include"
diff --git a/math/p5-Math-BigRat/Makefile b/math/p5-Math-BigRat/Makefile
index 47ee2f06fa7b..69c41b8ac0ae 100644
--- a/math/p5-Math-BigRat/Makefile
+++ b/math/p5-Math-BigRat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Math-BigRat
PORTVERSION= 0.25
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Arbitrary big rational numbers
-BUILD_DEPENDS= p5-Math-BigInt>=1.88:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Math::BigRat.3
diff --git a/math/p5-Math-FixedPrecision/Makefile b/math/p5-Math-FixedPrecision/Makefile
index 604336e1bc63..1e168fca5a10 100644
--- a/math/p5-Math-FixedPrecision/Makefile
+++ b/math/p5-Math-FixedPrecision/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Math-FixedPrecision
PORTVERSION= 0.21
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module that provides decimal math without floating point errors
-BUILD_DEPENDS= ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Math::FixedPrecision.3
diff --git a/math/p5-Math-NumberCruncher/Makefile b/math/p5-Math-NumberCruncher/Makefile
index f5b21f413057..8a734fae5939 100644
--- a/math/p5-Math-NumberCruncher/Makefile
+++ b/math/p5-Math-NumberCruncher/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Math-NumberCruncher
PORTVERSION= 5.00
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Collection of useful math-related functions
-BUILD_DEPENDS= p5-Math-BigInt>=0:${PORTSDIR}/math/p5-Math-BigInt
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Math::NumberCruncher.3
diff --git a/math/p5-Math-RandomOrg/Makefile b/math/p5-Math-RandomOrg/Makefile
index ab38a27a71a2..a51e87aa5d69 100644
--- a/math/p5-Math-RandomOrg/Makefile
+++ b/math/p5-Math-RandomOrg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Math-RandomOrg
PORTVERSION= 0.04
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Retrieve random numbers and data from random.org
-BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Math::RandomOrg.3
diff --git a/math/p5-Number-WithError/Makefile b/math/p5-Number-WithError/Makefile
index ff86f3d32702..0c74ce758484 100644
--- a/math/p5-Number-WithError/Makefile
+++ b/math/p5-Number-WithError/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Number-WithError
PORTVERSION= 0.08
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,8 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Numbers with error propagation and scientific rounding
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
- ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork \
- ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt
+ ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Number::WithError.3