aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile4
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/dieharder/Makefile1
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/octave-forge-gsl/Makefile4
-rw-r--r--math/orpie/Makefile4
-rw-r--r--math/p5-Math-GSL/Makefile4
-rw-r--r--math/pspp/Makefile2
-rw-r--r--math/py-gsl/Makefile4
-rw-r--r--math/qtiplot/Makefile4
-rw-r--r--math/ruby-gsl/Makefile4
11 files changed, 20 insertions, 19 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 8ec4db3379c2..52a2f964e3eb 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,7 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math perl5
MASTER_SITES= CPAN/${PORTNAME}:cpan \
SF/pdl/PDL/${PORTVERSION}:sf
@@ -26,7 +26,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.9:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.14:${PORTSDIR}/math/gsl
+ gsl.15:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 922cf8f9d0d8..0a802831b8ca 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 1.91
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}/old/${PORTVERSION}
@@ -18,7 +18,7 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= A powerful script-based vector graphics language
.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.14:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.15:${PORTSDIR}/math/gsl
.endif
.if defined(WITH_FFTW)
LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 40b566da7ebf..68abac5ccbbf 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dieharder
DISTVERSION= 3.29.4beta
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.phy.duke.edu/~rgb/General/dieharder/
EXTRACT_SUFX= .tgz
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 567849dad81d..5d803d254a0d 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.6.0.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= math kde
MASTER_SITES= SF
@@ -17,7 +17,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jasper.4:${PORTSDIR}/graphics/jasper \
MagickWand.3:${PORTSDIR}/graphics/ImageMagick \
- gsl.14:${PORTSDIR}/math/gsl \
+ gsl.15:${PORTSDIR}/math/gsl \
fftw3.5:${PORTSDIR}/math/fftw3 \
qwtplot3d.0:${PORTSDIR}/math/qwtplot3d \
origin.0:${PORTSDIR}/math/liborigin
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
index ccb74fdef0a1..d0ef07d369b0 100644
--- a/math/octave-forge-gsl/Makefile
+++ b/math/octave-forge-gsl/Makefile
@@ -7,13 +7,13 @@
PORTNAME= octave-forge-gsl
PORTVERSION= 1.0.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MAINTAINER= stephen@missouri.edu
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
post-patch:
@${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/config*
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 2019e9a64375..278509da3bb9 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= math
MASTER_SITES= http://pessimization.com/software/orpie/
@@ -15,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index d24e1ddd1a35..b61d68818660 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.20
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,7 +18,7 @@ COMMENT= A perl interface to GNU Scientific Library
BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/PkgConfig.pm:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${SITE_PERL}/Test/Class.pm:${PORTSDIR}/devel/p5-Test-Class
-LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
PERL_CONFIGURE= yes
PERL_MODBUILD= yes
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index c7083a67baf3..bed7197730d0 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pspp
PORTVERSION= 0.6.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= GNU
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 7bc07ae5025c..81129c76a405 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/py${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +19,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/include/numpy/arrayobject.h:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy
-LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 221ad6d61ab1..2fc9e61122ea 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qtiplot
DISTVERSION= 0.9.7.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math science
MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
@@ -15,7 +15,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser
-LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl \
boost_date_time:${PORTSDIR}/devel/boost-libs
# use bundled modified libraries
# qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index c23f8e3d0f73..ed526d52dfc3 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsl
PORTVERSION= 1.10.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= rb-${PORTNAME}
@@ -18,7 +18,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby extension library for GSL (GNU Scientific Library)
-LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
USE_RUBY= yes
USE_RUBY_SETUP= yes