aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/metis-edf/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/metis-edf/Makefile b/math/metis-edf/Makefile
index 329199862787..be4ebe312cef 100644
--- a/math/metis-edf/Makefile
+++ b/math/metis-edf/Makefile
@@ -29,6 +29,12 @@ PROGS= kmetis onmetis.exe pmetis
MACHINEARCH= ${ARCH}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700000
+WITH_FORTRAN= yes
+.endif
+
pre-configure:
.if ${MACHINEARCH} != "i386"
@${FIND} ${WRKSRC} -type f -name "*.c" -o -name "*.h" | ${XARGS} \
@@ -56,4 +62,4 @@ post-install:
@${ECHO_MSG} "===> Test file installed in ${EXAMPLESDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>