aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/abakus/Makefile3
-rw-r--r--math/acalc/Makefile3
-rw-r--r--math/plplot/Makefile7
-rw-r--r--math/py-matplotlib/Makefile6
-rw-r--r--math/qtiplot/Makefile3
-rw-r--r--math/qtoctave/Makefile3
-rw-r--r--math/qwtplot3d-qt4/Makefile3
-rw-r--r--math/vtk6/Makefile3
-rw-r--r--math/vtk8/Makefile5
9 files changed, 36 insertions, 0 deletions
diff --git a/math/abakus/Makefile b/math/abakus/Makefile
index 01837a72dc9a..48bfa16fc8bd 100644
--- a/math/abakus/Makefile
+++ b/math/abakus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Simple KDE Calculator
LICENSE= GPLv2
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2018-12-31
+
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
LIB_DEPENDS= libmpfr.so:math/mpfr
diff --git a/math/acalc/Makefile b/math/acalc/Makefile
index e61bf2ebfa0c..881239486ad9 100644
--- a/math/acalc/Makefile
+++ b/math/acalc/Makefile
@@ -10,6 +10,9 @@ COMMENT= Simple and pretty Qt4-based expression calculator
LICENSE= BSD4CLAUSE
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
USE_GITHUB= yes
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 34b6d4bb8b25..35825c3ddc66 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -108,6 +108,13 @@ WXGTK_CMAKE_ON= -DwxWidgets_CONFIG_EXECUTABLE:FILEPATH="${WX_CONFIG}"
X11_USE= XORG=ice,sm,x11,xext
X11_CMAKE_BOOL= PLD_xcairo PLD_xwin
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQT4}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
post-patch:
${REINPLACE_CMD} -e \
's|dl dlopen|c dlopen|' \
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index aabb081ac061..c34a51dd84b2 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -84,6 +84,12 @@ TKAGGBACKEND_BUILD_DEPENDS+= Xvfb:x11-servers/xorg-vfbserver
WXAGGBACKEND_BUILD_DEPENDS= Xvfb:x11-servers/xorg-vfbserver
.endif
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MQT4AGG_BACKEND}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
post-extract:
${FIND} ${WRKSRC} -name \*.py | ${XARGS} ${CHMOD} -x
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index d3aba35adf5c..f18201db7ca4 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
MAINTAINER= makc@FreeBSD.org
COMMENT= Data analysis and scientific plotting
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
LIB_DEPENDS= libgsl.so:math/gsl \
libmuparser.so:math/muparser \
libpng.so:graphics/png
diff --git a/math/qtoctave/Makefile b/math/qtoctave/Makefile
index 6d1308e2bcc5..763f9a95c495 100644
--- a/math/qtoctave/Makefile
+++ b/math/qtoctave/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= http://forja.rediris.es/frs/download.php/2054/
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt 4 frontend for Octave
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
RUN_DEPENDS= octave:math/octave
USE_QT= designer gui network script svg xml \
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index a14495737ed6..50356b485bff 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -10,6 +10,9 @@ PKGNAMESUFFIX= -qt4
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D plotting widgets for scientific data and math expressions
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
USES= dos2unix qmake qt:4 tar:tgz
USE_QT= gui moc_build opengl
USE_GL= glu
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index f1668fe16144..c728b2347a3a 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -126,6 +126,9 @@ PLIST_SUB+= MPI="@comment "
.endif
.if ${PORT_OPTIONS:MQT4}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
USES+= qt:4
USE_QT= gui_build gui_run network_build network_run sql_build sql_run \
moc_build uic_build qmake_build rcc_build opengl webkit_build \
diff --git a/math/vtk8/Makefile b/math/vtk8/Makefile
index 5ee5457b791b..5dfb62df0313 100644
--- a/math/vtk8/Makefile
+++ b/math/vtk8/Makefile
@@ -107,6 +107,11 @@ post-patch:
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MQT4}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
.for g in ${VTK_GROUPS}
. if ${PORT_OPTIONS:M${g}}
CMAKE_ARGS+= -DVTK_Group_${g}:BOOL=ON