aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/gambit/Makefile5
-rw-r--r--math/gambit/distinfo6
-rw-r--r--math/gambit/files/patch-library_src_linalg_btableau.cc18
-rw-r--r--math/gambit/files/patch-library_src_linalg_lemketab.cc13
-rw-r--r--math/gambit/files/patch-library_src_linalg_lhtab.cc17
-rw-r--r--math/gambit/files/patch-library_src_linalg_lptab.cc14
-rw-r--r--math/gambit/files/patch-library_src_linalg_ludecomp.cc17
-rw-r--r--math/gambit/files/patch-library_src_matrix.cc (renamed from math/gambit/files/patch-src_libgambit_matrix.cc)4
-rw-r--r--math/gambit/files/patch-src-labenski-src_sheet.cpp14
-rw-r--r--math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc10
-rw-r--r--math/gambit/pkg-plist6
11 files changed, 94 insertions, 30 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index e563a8a7c9dc..824e28303502 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gambit
-DISTVERSION= 15.1.1
-PORTREVISION= 1
+DISTVERSION= 16.0.1
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PORTVERSION:R:R}/${PORTVERSION}
@@ -13,7 +12,7 @@ COMMENT= Library of tools for doing computation in game theory
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lib
+USES= compiler:c++11-lib gnome
GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_WX= 3.0
diff --git a/math/gambit/distinfo b/math/gambit/distinfo
index 8bb77789e5f4..0eea420c98af 100644
--- a/math/gambit/distinfo
+++ b/math/gambit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531253300
-SHA256 (gambit-15.1.1.tar.gz) = 7ede51739dc868242886815bb875307f5e11bb3789f22c546d3c83194fe75a1c
-SIZE (gambit-15.1.1.tar.gz) = 1777714
+TIMESTAMP = 1543682971
+SHA256 (gambit-16.0.1.tar.gz) = dbec0fc8c4cd3ad6b6a898a1330407fd7aa1bbac31ed94b6e96aa7e7196185f5
+SIZE (gambit-16.0.1.tar.gz) = 1802541
diff --git a/math/gambit/files/patch-library_src_linalg_btableau.cc b/math/gambit/files/patch-library_src_linalg_btableau.cc
new file mode 100644
index 000000000000..841916d62017
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_btableau.cc
@@ -0,0 +1,18 @@
+--- library/src/linalg/btableau.cc.orig 2018-12-01 17:24:33 UTC
++++ library/src/linalg/btableau.cc
+@@ -24,8 +24,7 @@
+ #include "gambit/matrix.imp"
+ #include "gambit/linalg/btableau.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class BaseTableau<double>;
+ template class BaseTableau<Rational>;
+@@ -33,4 +32,4 @@ template class BaseTableau<Rational>;
+ template class TableauInterface<double>;
+ template class TableauInterface<Rational>;
+
+-
++}
diff --git a/math/gambit/files/patch-library_src_linalg_lemketab.cc b/math/gambit/files/patch-library_src_linalg_lemketab.cc
new file mode 100644
index 000000000000..1cc652c90a1a
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_lemketab.cc
@@ -0,0 +1,13 @@
+--- library/src/linalg/lemketab.cc.orig 2018-12-01 17:13:48 UTC
++++ library/src/linalg/lemketab.cc
+@@ -22,7 +22,9 @@
+
+ #include "gambit/linalg/lemketab.imp"
+
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class LemkeTableau<double>;
+ template class LemkeTableau<Gambit::Rational>;
++
++}
diff --git a/math/gambit/files/patch-library_src_linalg_lhtab.cc b/math/gambit/files/patch-library_src_linalg_lhtab.cc
new file mode 100644
index 000000000000..d55e1ba15f20
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_lhtab.cc
@@ -0,0 +1,17 @@
+--- library/src/linalg/lhtab.cc.orig 2018-12-01 17:29:54 UTC
++++ library/src/linalg/lhtab.cc
+@@ -22,12 +22,11 @@
+
+ #include "gambit/linalg/lhtab.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class LHTableau<double>;
+ template class LHTableau<Rational>;
+
+-
++}
+
+
diff --git a/math/gambit/files/patch-library_src_linalg_lptab.cc b/math/gambit/files/patch-library_src_linalg_lptab.cc
new file mode 100644
index 000000000000..8f8f7b891910
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_lptab.cc
@@ -0,0 +1,14 @@
+--- library/src/linalg/lptab.cc.orig 2017-05-12 11:07:26 UTC
++++ library/src/linalg/lptab.cc
+@@ -22,8 +22,9 @@
+
+ #include "gambit/linalg/lptab.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class LPTableau<double>;
+ template class LPTableau<Rational>;
++
++}
diff --git a/math/gambit/files/patch-library_src_linalg_ludecomp.cc b/math/gambit/files/patch-library_src_linalg_ludecomp.cc
new file mode 100644
index 000000000000..a44fc2ebeeb3
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_ludecomp.cc
@@ -0,0 +1,17 @@
+--- library/src/linalg/ludecomp.cc.orig 2017-05-12 11:07:26 UTC
++++ library/src/linalg/ludecomp.cc
+@@ -22,11 +22,12 @@
+
+ #include "gambit/linalg/ludecomp.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class EtaMatrix<double>;
+ template class LUdecomp<double>;
+
+ template class EtaMatrix<Rational>;
+ template class LUdecomp<Rational>;
++
++}
diff --git a/math/gambit/files/patch-src_libgambit_matrix.cc b/math/gambit/files/patch-library_src_matrix.cc
index 8139197f2499..57f331fd9a61 100644
--- a/math/gambit/files/patch-src_libgambit_matrix.cc
+++ b/math/gambit/files/patch-library_src_matrix.cc
@@ -1,5 +1,5 @@
---- src/libgambit/matrix.cc.orig 2014-06-06 16:33:54.000000000 +0400
-+++ src/libgambit/matrix.cc 2015-04-13 21:39:08.802909000 +0300
+--- library/src/matrix.cc.orig 2018-12-01 16:51:25 UTC
++++ library/src/matrix.cc
@@ -25,11 +25,15 @@
using namespace Gambit;
diff --git a/math/gambit/files/patch-src-labenski-src_sheet.cpp b/math/gambit/files/patch-src-labenski-src_sheet.cpp
deleted file mode 100644
index b3d63f5fca12..000000000000
--- a/math/gambit/files/patch-src-labenski-src_sheet.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/labenski/src/sheet.cpp.orig 2013-06-24 11:57:48.000000000 +0200
-+++ src/labenski/src/sheet.cpp 2013-06-24 12:00:50.000000000 +0200
-@@ -7098,9 +7098,9 @@
- wxPrintf(wxT("COUNT MISMATCH ERROR! \n"));
-
- for (size_t n = 0; n < wxMin(ans.GetCount(), res.GetCount()); n++)
-- if (ans[n] != res[n]) wxPrintf(wxT("Error in item %u\n"), n);
-+ if (ans[n] != res[n]) wxPrintf(wxT("Error in item %zu\n"), n);
-
-- wxPrintf(msg + wxT("\n"));
-+ wxPrintf("%s\n", msg.ToAscii());
- }
-
- #define CSVT1(str, a1) { wxArrayString ar; ar.Add(wxT(a1)); CSV_TEST(wxT(str), ar, ParseLine(wxT(str))); }
diff --git a/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc b/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
index 3259dd1b445a..850ceacc8edf 100644
--- a/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
+++ b/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
@@ -1,6 +1,6 @@
---- src/tools/enumpoly/pelqhull.cc.orig 2014-05-27 12:07:04.000000000 +0400
-+++ src/tools/enumpoly/pelqhull.cc 2015-04-13 20:35:03.596285000 +0300
-@@ -2792,7 +2792,7 @@
+--- src/tools/enumpoly/pelqhull.cc.orig 2016-06-30 09:03:18 UTC
++++ src/tools/enumpoly/pelqhull.cc
+@@ -2792,7 +2792,7 @@ void qh_allstatA (void) {
/* zdef_(type,name,doc,average) */
zzdef_(zdoc, Zdoc2, "precision statistics", -1);
@@ -9,7 +9,7 @@
zdef_(wadd, Wnewvertex, "ave. distance of a new vertex to a facet (not 0s)", Znewvertex);
zdef_(wmax, Wnewvertexmax, "max. distance of a new vertex to a facet", -1);
zdef_(wmax, Wvertexmax, "max. distance of an output vertex to a facet", -1);
-@@ -2831,7 +2831,7 @@
+@@ -2831,7 +2831,7 @@ void qh_allstatB (void) {
zzdef_(zinc, Zsetplane, "facets created altogether", -1);
zdef_(zinc, Ztotridges, "ridges created altogether", -1);
zdef_(zinc, Zpostfacets, "facets before post merge", -1);
@@ -18,7 +18,7 @@
zdef_(wadd, Wangle, "average angle (cosine) for all ridges", Zangle);
zdef_(wmax, Wanglemax, "maximum angle (cosine) of a ridge", -1);
zdef_(wmin, Wanglemin, "minimum angle (cosine) of a ridge", -1);
-@@ -2946,7 +2946,7 @@
+@@ -2946,7 +2946,7 @@ void qh_allstatF(void) {
zdef_(zinc, Zintersect, "intersections found redundant vertices", -1);
zdef_(zadd, Zintersecttot, " ave. number found per vertex", Zintersect);
zdef_(zmax, Zintersectmax, " max. found for a vertex", -1);
diff --git a/math/gambit/pkg-plist b/math/gambit/pkg-plist
index ed36c77d018d..b58baac9ca97 100644
--- a/math/gambit/pkg-plist
+++ b/math/gambit/pkg-plist
@@ -10,15 +10,14 @@ bin/gambit-liap
bin/gambit-logit
bin/gambit-lp
bin/gambit-simpdiv
-include/libagg/GrayComposition.h
include/libagg/agg.h
include/libagg/bagg.h
include/libagg/gameagg.h
include/libagg/gamebagg.h
+include/libagg/gray.h
include/libagg/proj_func.h
include/libagg/trie_map.h
include/libagg/trie_map.imp
-include/libgambit/GrayComposition.h
include/libgambit/agg.h
include/libgambit/array.h
include/libgambit/bagg.h
@@ -29,11 +28,12 @@ include/libgambit/behavspt.h
include/libgambit/dvector.h
include/libgambit/dvector.imp
include/libgambit/function.h
+include/libgambit/gambit.h
include/libgambit/game.h
include/libgambit/gameagg.h
include/libgambit/gamebagg.h
+include/libgambit/gray.h
include/libgambit/integer.h
-include/libgambit/libgambit.h
include/libgambit/list.h
include/libgambit/matrix.h
include/libgambit/matrix.imp
an class='deletions'>-2/+2 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-031-2/+2 * Update to 4.0.4.jkim2013-06-201-4/+4 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-192-4/+2 * Update to 4.0.3.jkim2013-05-101-4/+4 * Add some shebangfix to allow building most of the ports tree without /usr/bin...bapt2013-05-071-5/+3 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * Update to 4.0.2.jkim2013-04-171-4/+4 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-273-6/+8 * Update to 4.0.1.jkim2013-03-091-4/+4 * Update to 3.6.5.jkim2013-02-051-4/+4 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-043-18/+18 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-301-0/+3 * - Update to 3.5.7.jkim2012-10-272-9/+4 * - Update to 3.5.6.jkim2012-08-241-4/+4 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-181-4/+4 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-011-4/+4 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-152-3/+2 * - update png to 1.5.10dinoex2012-06-012-1/+2 * - Remove koffice-i18n ports, as they are not very useful withoutavilla2012-05-315-59/+0 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-252-10/+12 * - upgrade to 3.5.2bapt2012-04-234-0/+22 * - Add my LOCAL to MASTER_SITESsunpoet2012-04-181-1/+2 * - update to 1.2bapt2012-04-102-5/+4 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-251-2/+2 * - Pass maintainership to office@FreeBSD.orgsunpoet2011-11-291-1/+1 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-141-2/+2 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-172-4/+11 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-2/+3 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-2/+2 * - Pet portlint(1)culot2011-08-092-5/+4 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-291-10/+10 * - Fix typosunpoet2011-07-251-1/+1 * Pass matainership to the new office teambapt2011-07-221-1/+1 * Add hebrew hunspell dictionnarybapt2011-07-204-0/+43 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-082-2/+2 * Update KDE Software Compilation ports to 4.6.5makc2011-07-082-2/+22 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-141-2/+2 * Update KDE Software Compilation ports to 4.6.3makc2011-05-171-2/+2 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-071-2/+2 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-252-10/+25 * - Get Rid MD5 supportmiwi2011-03-197-7/+0 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-081-2/+2 * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-031-2/+2 * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-041-3/+2 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-061-3/+3 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-162-4/+2 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-032-41/+8 * Update to 1.1makc2010-08-012-5/+5 * Present KDE SC 4.4.5 for FreeBSD.makc2010-06-301-3/+3 * Present KDE SC 4.4.4 for FreeBSD.makc2010-06-022-3/+6 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-312-2/+2 * - The FreeBSD KDE team is pleased to announce KDE SC 4.4.3 for FreeBSDfluffy2010-05-113-15/+37 * - update to 1.4.1dinoex2010-03-283-2/+3 * Presenting KDE 4.3.5 for FreeBSD. The official release notes for thismiwi2010-02-072-4/+3 * - update to jpeg-8dinoex2010-02-053-2/+3 * - use $SUB_FILES to dynamically adjust pkg-messagepgollucci2010-01-312-1/+3 * For ports maintained by ports@FreeBSD.org, remove names and/ordougb2009-12-211-3/+0 * The FreeBSD KDE is please to announce the release of KDE 4.3.4,miwi2009-12-021-3/+3 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.3miwi2009-11-272-5/+10 * - Remove hebrew/geresh; no longer maintained upstreamtabthorpe2009-10-086-108/+0 * The FreeBSD KDE is please to announce the release of KDE 4.3.1,tabthorpe2009-09-022-4/+4 * These ports need an update to work with the new paragraph embedding levelmarcus2009-08-241-0/+2 * Chase the fribidi shared lib bump.marcus2009-08-231-1/+2 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-221-1/+1 * clean upmakc2009-08-081-3/+0 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.0miwi2009-08-053-14/+14 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-313-1/+3 * The KDE FreeBSD team is pleased to announce KDE 4.2.4, the last bugfixmiwi2009-06-032-6/+6 * Update KDE ports to 4.2.3makc2009-05-102-3/+8 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.2miwi2009-04-022-4/+4 * Update KDE to 4.2.1.makc2009-03-092-4/+3 * Geresh is a multi lingual text editor, but there are a few featurestabthorpe2009-02-246-0/+105 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.0miwi2009-02-095-330/+157 * Update to 1.0,makc2009-01-25