aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/lambda/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/lambda/Makefile b/math/lambda/Makefile
index 58b723b45958..e6c55481a6d5 100644
--- a/math/lambda/Makefile
+++ b/math/lambda/Makefile
@@ -11,7 +11,7 @@ COMMENT= Lambda calculus interpreter
LICENSE= GPLv2
-USES= perl5 readline shebangfix
+USES= perl5 ncurses readline shebangfix
USE_PERL5= build
SHEBANG_FILES= docs/trans_xml_for_cat.pl
GNU_CONFIGURE= yes
@@ -25,6 +25,10 @@ PLIST_FILES= bin/lambda \
DOCS= lambda.html lambdamanual.html user_manual_style.css
PORTDOCS= *
+post-patch:
+ ${REINPLACE_CMD} -e 's|-ltermcap|-lncurses|' ${WRKSRC}/configure \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lambda ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}