aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-BigInt-Lite/Makefile24
-rw-r--r--math/p5-Math-BigInt-Lite/distinfo3
-rw-r--r--math/p5-Math-BigInt-Lite/pkg-descr15
-rw-r--r--math/p5-Math-BigInt-Lite/pkg-plist2
5 files changed, 45 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 57404b6c6600..cb511530fc49 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -434,6 +434,7 @@
SUBDIR += p5-Math-BigInt
SUBDIR += p5-Math-BigInt-FastCalc
SUBDIR += p5-Math-BigInt-GMP
+ SUBDIR += p5-Math-BigInt-Lite
SUBDIR += p5-Math-BigInt-Pari
SUBDIR += p5-Math-BigRat
SUBDIR += p5-Math-CDF
diff --git a/math/p5-Math-BigInt-Lite/Makefile b/math/p5-Math-BigInt-Lite/Makefile
new file mode 100644
index 000000000000..7ee30106136c
--- /dev/null
+++ b/math/p5-Math-BigInt-Lite/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Math-BigInt-Lite
+PORTVERSION= 0.16
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= What Math::BigInts are before they become big
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-Math-BigInt>=1.999801:math/p5-Math-BigInt
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-BigInt-Lite/distinfo b/math/p5-Math-BigInt-Lite/distinfo
new file mode 100644
index 000000000000..60a89770ae7b
--- /dev/null
+++ b/math/p5-Math-BigInt-Lite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481546184
+SHA256 (Math-BigInt-Lite-0.16.tar.gz) = 314908e10ec1259373497b9a44231f0eb42005945912c2027e732898c1885670
+SIZE (Math-BigInt-Lite-0.16.tar.gz) = 73427
diff --git a/math/p5-Math-BigInt-Lite/pkg-descr b/math/p5-Math-BigInt-Lite/pkg-descr
new file mode 100644
index 000000000000..f83d4bd52a52
--- /dev/null
+++ b/math/p5-Math-BigInt-Lite/pkg-descr
@@ -0,0 +1,15 @@
+Math::BigInt is not very good suited to work with small (read: typical less than
+10 digits) numbers, since it has a quite high per-operation overhead and is thus
+much slower than normal Perl for operations.
+
+But for some applications, you want fast speed for small numbers without the
+risk of overflowing. This is were Math::BigInt::Lite comes into play.
+
+Math::BigInt::Lite objects should behave in every way like Math::BigInt objects,
+that is apart from the different label, you should not be able to tell the
+difference. Since Math::BigInt::Lite is designed with speed in mind, there are
+certain limitations build-in. In praxis, however, you will not feel them,
+because everytime something gets to big to pass as Lite (literally), it will
+upgrade the objects and operation in question to Math::BigInt.
+
+WWW: http://search.cpan.org/dist/Math-BigInt-Lite/
diff --git a/math/p5-Math-BigInt-Lite/pkg-plist b/math/p5-Math-BigInt-Lite/pkg-plist
new file mode 100644
index 000000000000..ef015656bd85
--- /dev/null
+++ b/math/p5-Math-BigInt-Lite/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Math/BigInt/Lite.pm
+%%PERL5_MAN3%%/Math::BigInt::Lite.3.gz