aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 25346a85e523..47c1980ce810 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -24,6 +24,12 @@ INSTALLS_SHLIB= yes
USE_REINPLACE= yes
PKGNAMESUFFIX= -devel
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501000 && ${MACHINE_ARCH} == "alpha"
+USE_GCC=3.3
+.endif
+
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -pipe -O3 -ffast-math -finline-functions -fstrength-reduce -funroll-loops -fexpensive-optimizations
@@ -32,8 +38,6 @@ FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
.endif
-.include <bsd.port.pre.mk>
-
post-patch:
.if !defined(WITH_OPTIMIZED_FLAGS)
@${ECHO_CMD} "You can optimize lapack sub project by setting WITH_OPTIMIZED_FLAGS=yes."