aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
index 4ce2ccf2687c..9085ca0efd0f 100644
--- a/math/p5-Math-BigInt-GMP/Makefile
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -24,4 +24,9 @@ CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include"
MAN3= Math::BigInt::GMP.3
+post-patch:
+ @${PERL} -pi -e "s!-lgmp!-L${LOCALBASE}/lib $$&!;" \
+ -e "if (/'LIBS'/) { print qq!'INC' => '-I${LOCALBASE}/include',!; }" \
+ ${WRKSRC}/Makefile.PL
+
.include <bsd.port.mk>