aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pysym/Makefile22
-rw-r--r--math/py-pysym/distinfo3
-rw-r--r--math/py-pysym/pkg-descr9
4 files changed, 35 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index b3fe901dfd6b..9f50315759b8 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -672,6 +672,7 @@
SUBDIR += py-pymc
SUBDIR += py-pymc3
SUBDIR += py-pysparse
+ SUBDIR += py-pysym
SUBDIR += py-pyvtk
SUBDIR += py-roman
SUBDIR += py-scientific
diff --git a/math/py-pysym/Makefile b/math/py-pysym/Makefile
new file mode 100644
index 000000000000..b7b7a8bd62f3
--- /dev/null
+++ b/math/py-pysym/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= pysym
+DISTVERSION= 0.2.3
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Prototype package for symbolic manipulation
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sympy>0:math/py-sympy@${FLAVOR} \
+ ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-pysym/distinfo b/math/py-pysym/distinfo
new file mode 100644
index 000000000000..35ad42c780a1
--- /dev/null
+++ b/math/py-pysym/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522476382
+SHA256 (pysym-0.2.3.tar.gz) = c0ac6b5652e9c63aefab9de8816ddb71fa0c685b7eb455c08cbb607f6b26e244
+SIZE (pysym-0.2.3.tar.gz) = 13313
diff --git a/math/py-pysym/pkg-descr b/math/py-pysym/pkg-descr
new file mode 100644
index 000000000000..4350acd09a94
--- /dev/null
+++ b/math/py-pysym/pkg-descr
@@ -0,0 +1,9 @@
+pysym is an experimental Python package for symbolic manipulation with limited
+scope (as in minimal). It tries to stay compatible with the API of SymPy. It
+should be viewed as a prototype and not as a "production" package.
+
+The capabilities include:
+* Differentiation
+* (slow) numerical evaluation (including "lambdify" support)
+
+WWW: https://github.com/bjodah/pysym