aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/py-rpy2/Makefile17
-rw-r--r--math/py-rpy2/distinfo6
-rw-r--r--math/py-rpy2/files/patch-rpy2-situation.py (renamed from math/py-rpy2/files/patch-rpy-situation.py)6
3 files changed, 16 insertions, 13 deletions
diff --git a/math/py-rpy2/Makefile b/math/py-rpy2/Makefile
index 07042234f75f..39ecce2191ba 100644
--- a/math/py-rpy2/Makefile
+++ b/math/py-rpy2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rpy2
-DISTVERSION= 3.1.0
-PORTREVISION= 1
+DISTVERSION= 3.2.0
CATEGORIES= math
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,12 +13,12 @@ COMMENT= Python interface to the R Programming Language
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/gpl-2.0.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.10.0:devel/py-cffi@${PY_FLAVOR}
LIB_DEPENDS= libR.so:math/R \
libicui18n.so:devel/icu \
libomp.so:devel/openmp \
libpcre.so:devel/pcre
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.10.0:devel/py-cffi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
@@ -29,9 +28,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR} \
USES= fortran python:3.5+ readline
USE_PYTHON= autoplist distutils
-NO_ARCH= yes
+MAKE_ENV= RPY2_CFFI_MODE=BOTH
-pre-build:
- cd ${WRKSRC}/ && ${PYTHON_CMD} rpy/_rinterface_cffi_build.py
+PLIST_FILES= ${PYTHON_SITELIBDIR}/__pycache__/_rinterface_cffi_abi.cpython-${PYTHON_SUFFIX}.${PYTHON_PYOEXTENSION} \
+ ${PYTHON_SITELIBDIR}/__pycache__/_rinterface_cffi_abi.cpython-${PYTHON_SUFFIX}.pyc \
+ ${PYTHON_SITELIBDIR}/_rinterface_cffi_abi.py
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_rinterface_cffi_api.abi3.so
.include <bsd.port.mk>
diff --git a/math/py-rpy2/distinfo b/math/py-rpy2/distinfo
index af2013c4d6e1..af6129126557 100644
--- a/math/py-rpy2/distinfo
+++ b/math/py-rpy2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1567451240
-SHA256 (rpy2-3.1.0.tar.gz) = ed4284df32d00b1fba5b1409e5df64b04b02d47aff543d6ef1dc211ab94e247f
-SIZE (rpy2-3.1.0.tar.gz) = 158773
+TIMESTAMP = 1569809145
+SHA256 (rpy2-3.2.0.tar.gz) = 18025f53c1a32b7b38ed319c81f8445b9a8809e0ecba210634b67764d68da978
+SIZE (rpy2-3.2.0.tar.gz) = 161566
diff --git a/math/py-rpy2/files/patch-rpy-situation.py b/math/py-rpy2/files/patch-rpy2-situation.py
index 474f0827b7f5..3749eabee427 100644
--- a/math/py-rpy2/files/patch-rpy-situation.py
+++ b/math/py-rpy2/files/patch-rpy2-situation.py
@@ -1,6 +1,6 @@
---- rpy/situation.py.orig 2019-05-05 16:29:19 UTC
-+++ rpy/situation.py
-@@ -63,7 +63,7 @@ def r_home_from_registry():
+--- rpy2/situation.py.orig 2019-09-27 19:59:40 UTC
++++ rpy2/situation.py
+@@ -90,7 +90,7 @@ def r_home_from_registry() -> Optional[s
def get_rlib_path(r_home: str, system: str) -> str:
"""Get the path for the R shared library."""