aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/cln/Makefile8
-rw-r--r--math/cln/files/patch-src_base_cl__low.h29
2 files changed, 36 insertions, 1 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index a124085a738d..09ea89a18f42 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -23,4 +23,10 @@ INFO= cln
BROKEN_sparc64= Does not compile on sparc64
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == armv6
+CPPFLAGS+= -DNO_ASM
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/cln/files/patch-src_base_cl__low.h b/math/cln/files/patch-src_base_cl__low.h
new file mode 100644
index 000000000000..7177af422b36
--- /dev/null
+++ b/math/cln/files/patch-src_base_cl__low.h
@@ -0,0 +1,29 @@
+--- src/base/cl_low.h.orig 2015-01-28 09:25:18 UTC
++++ src/base/cl_low.h
+@@ -207,7 +207,7 @@ inline uint32 mulu32_unchecked (uint32 a
+ // declared inside a namespace!
+ } extern "C" uint32 mulu32_high; namespace cln { // -> High-Teil
+ #else
+- extern "C" uint32 mulu32_high; // -> High-Teil
++} extern "C" uint32 mulu32_high; namespace cln { // -> High-Teil
+ #endif
+ #if defined(__GNUC__) && defined(__m68k__) && !defined(NO_ASM)
+ #define mulu32(x,y,hi_zuweisung,lo_zuweisung) \
+@@ -439,7 +439,7 @@ inline uint32 mulu32_unchecked (uint32 a
+ // Workaround MSVC compiler bug.
+ } extern "C" uint16 divu_16_rest; namespace cln { // -> Rest r
+ #else
+- extern "C" uint16 divu_16_rest; // -> Rest r
++} extern "C" uint16 divu_16_rest; namespace cln { // -> Rest r
+ #endif
+ #endif
+ #if defined(__GNUC__) && defined(__sparc64__) && !defined(NO_ASM)
+@@ -589,7 +589,7 @@ inline uint32 mulu32_unchecked (uint32 a
+ // Workaround MSVC compiler bug.
+ } extern "C" uint32 divu_32_rest; namespace cln { // -> Rest r
+ #else
+- extern "C" uint32 divu_32_rest; // -> Rest r
++} extern "C" uint32 divu_32_rest; namespace cln { // -> Rest r
+ #endif
+ #if defined(__GNUC__) && defined(__sparc64__) && !defined(NO_ASM)
+ #define divu_3232_3232(x,y,q_zuweisung,r_zuweisung) \