aboutsummaryrefslogtreecommitdiffstats
path: root/misc/amanda32-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/amanda32-server/Makefile')
-rw-r--r--misc/amanda32-server/Makefile51
1 files changed, 26 insertions, 25 deletions
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 1d1bc274cfb7..e707f6eaee5b 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= amanda
-PORTVERSION= 2.5.1p3
-PORTREVISION?= 5
-PKGNAMESUFFIX?= -server
+PORTVERSION= 2.6.0p2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= amanda
+PKGNAMESUFFIX?= -server
MAINTAINER= kuriyama@FreeBSD.org
COMMENT?= The Advanced Maryland Automatic Network Disk Archiver (server)
@@ -21,15 +20,20 @@ WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda-client
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-USE_AUTOTOOLS= autoconf:262
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig glib20
USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
+ --without-amlibexecdir \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
--disable-libtool --prefix=${PREFIX} \
- --with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
+ --disable-glibtest \
+ --with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP} \
+ --with-bsdtcp-security --with-bsdudp-security
+
USE_LDCONFIG= yes
WANT_PERL= yes
@@ -61,10 +65,6 @@ CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
CONFIGURE_ARGS+= --with-ssh-security
.endif
-# AMANDA_PORTRANGE is obsoleted. Use AMANDA_TCPPORTRANGE instead.
-.if defined (AMANDA_PORTRANGE)
-AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
-.endif
.if defined (AMANDA_TCPPORTRANGE)
CONFIGURE_ARGS+= --with-tcpportrange=${AMANDA_TCPPORTRANGE}
.endif
@@ -103,24 +103,22 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
-post-patch:
- @${REINPLACE_CMD} \
- -e 's|^OPENSSL=.*$$|OPENSSL=${OPENSSLBASE}/bin/openssl|' \
- ${WRKSRC}/server-src/amcrypt-ossl.sh.in \
- ${WRKSRC}/server-src/amcrypt-ossl-asym.sh.in
-
USE_PERL5= yes
+CONFLICTS= amanda-server-2.5.*
-BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
-RUN_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
+BUILD_DEPENDS+= ${LOCALBASE}/lib/amanda/libamandad-${PORTVERSION}.so:${PORTSDIR}/misc/amanda-client
+RUN_DEPENDS+= ${LOCALBASE}/lib/amanda/libamandad-${PORTVERSION}.so:${PORTSDIR}/misc/amanda-client
CONFIGURE_ARGS+=--without-client
-MAN8= amadmin.8 amaespipe.8 amcheck.8 \
- amcheckdb.8 amcleanup.8 \
- amcrypt.8 amcrypt-ossl-asym.8 amcrypt-ossl.8 amdd.8 \
- amdump.8 amfetchdump.8 amflush.8 amgetconf.8 amlabel.8 ammt.8 \
- amoverview.8 amreport.8 amrmtape.8 amstatus.8 \
+MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
+ amcheckdb.8 amcheckdump.8 amcleanup.8 \
+ amcrypt.8 amcryptsimple.8 amcrypt-ossl-asym.8 amcrypt-ossl.8 \
+ amdd.8 amdevcheck.8 \
+ amdump.8 amfetchdump.8 amflush.8 amgetconf.8 amgpgcrypt.8 \
+ amlabel.8 ammt.8 \
+ amoverview.8 amreport.8 amrestore.8 amrmtape.8 \
+ amserverconfig.8 amstatus.8 \
amtape.8 amtoc.8 amverify.8 amverifyrun.8 amtapetype.8
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
@@ -194,10 +192,11 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
+CONFLICTS= amanda-client-2.5.*
CONFIGURE_ARGS+=--without-server
MAN5= amanda.conf.5 amanda-client.conf.5
-MAN8= amanda.8 amrecover.8 amrestore.8
+MAN8= amanda.8 amrecover.8
OPTIONS+= DUMP_SNAPSHOT "use snapshot by using dump -L" off
@@ -210,8 +209,8 @@ post-install:
${PREFIX}/share/examples/amanda
${MKDIR} ${AMANDA_GNUTAR_LISTDIR}
${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${AMANDA_GNUTAR_LISTDIR}
- ${TOUCH} /etc/amandates
- ${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} /etc/amandates
+ ${TOUCH} ${PREFIX}/var/amanda/amandates
+ ${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${PREFIX}/var/amanda/amandates
.if defined (WITH_DUMP_SNAPSHOT)
EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
@@ -222,5 +221,7 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
# Maintainer TODO:
# o amanda-server installs lib/libamandad.a which should be handled by
# amanda-client only.
+# o man pages have incorrect markups.
+# o pthread issue: http://wiki.zmanda.com/index.php/Installation/OS_Specific_Notes/Installing_Amanda_on_FreeBSD#Threading_and_-pthread
.include <bsd.port.post.mk>