aboutsummaryrefslogtreecommitdiffstats
path: root/misc/bb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/bb/Makefile')
-rw-r--r--misc/bb/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
new file mode 100644
index 000000000000..feb885fcadbe
--- /dev/null
+++ b/misc/bb/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: bb
+# Version required: 1.2
+# Date created: 22 June 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= bb-1.2
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.ta.jcu.cz/pub/aa/bb/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= aa\\.1\\.:${PORTSDIR}/graphics/aalib
+
+MAKEFILE= makefile
+GNU_CONFIGURE= yes
+
+pre-build:
+ @ cd ${WRKSRC}/mikunix; make
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bb ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bb_snd_server ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/bb
+.for file in bb bb2 bb3
+ @ ${INSTALL_DATA} ${WRKSRC}/${file}.s3m ${PREFIX}/share/bb
+.endfor
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/bb
+.for file in ANNOUNCE COPYING README
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/bb
+.endfor
+.endif
+
+.include <bsd.port.mk>