aboutsummaryrefslogtreecommitdiffstats
path: root/misc/biosfont-demos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/biosfont-demos/Makefile')
-rw-r--r--misc/biosfont-demos/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/misc/biosfont-demos/Makefile b/misc/biosfont-demos/Makefile
index dab07e1dea00..eece03828a34 100644
--- a/misc/biosfont-demos/Makefile
+++ b/misc/biosfont-demos/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= biosfont-demos
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= misc
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/
@@ -14,13 +14,13 @@ MAINTAINER= r.c.ladan@gmail.com
COMMENT= Demos for the biosfont kernel module
BUILD_DEPENDS= ${LOCALBASE}/include/biosfont.h:${PORTSDIR}/sysutils/biosfont
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= /boot/modules/biosfont.ko:${PORTSDIR}/sysutils/biosfont
PLIST_FILES= bin/showchar bin/showdati
do-build:
- ${CC} ${WRKSRC}/showchar.c -o ${WRKSRC}/showchar -I${LOCALBASE}/include
- ${CC} ${WRKSRC}/showdati.c -o ${WRKSRC}/showdati -I${LOCALBASE}/include -lcurses
+ ${CC} ${CFLAGS} ${WRKSRC}/showchar.c -o ${WRKSRC}/showchar -I${LOCALBASE}/include
+ ${CC} ${CFLAGS} ${WRKSRC}/showdati.c -o ${WRKSRC}/showdati -I${LOCALBASE}/include -lcurses
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/showchar ${PREFIX}/bin