aboutsummaryrefslogtreecommitdiffstats
path: root/misc/boxes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/boxes/Makefile')
-rw-r--r--misc/boxes/Makefile37
1 files changed, 23 insertions, 14 deletions
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
index ea25a849927f..2762a3c053bb 100644
--- a/misc/boxes/Makefile
+++ b/misc/boxes/Makefile
@@ -1,33 +1,37 @@
-# New ports collection makefile for: boxes
-# Date created: 3 March 2000
-# Whom: Patrick Seal (patseal@hyperhost.net)
-#
+# Created by: Patrick Seal <patseal@hyperhost.net>
# $FreeBSD$
-#
PORTNAME= boxes
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.1.1
CATEGORIES= misc
MASTER_SITES= http://boxes.thomasjensen.com/download/ \
- ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= utils/text
+ http://fossies.org/unix/privat/
+# SUNSITE/utils/text
EXTRACT_SUFX= .src.tar.gz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Draws ASCII-art configurable boxes around text or code
-MAN1= boxes.1
+LICENSE= GPLv2
+
USE_GMAKE= yes
USE_BISON= build
ALL_TARGET= boxes
MAKE_ARGS= CC="${CC}" GLOBALCONF=${GLOBALCONF} CFLAGS="${CFLAGS} -ansi -I. -Iregexp"
GLOBALCONF= ${DATADIR}/boxes-config
-PLIST_FILES= bin/boxes share/boxes/boxes-config
-PLIST_DIRS= share/boxes
-do-configure:
+PLIST_FILES= bin/boxes \
+ ${DATADIR_REL}/boxes-config
+PLIST_DIRS= ${DATADIR_REL}
+
+MAN1= boxes.1
+
+PORTDOCS= README
+
+.include <bsd.port.options.mk>
+
+post-patch:
${RM} ${WRKSRC}/src/boxes.h ${WRKSRC}/doc/boxes.1
do-install:
@@ -36,4 +40,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/boxes-config ${DATADIR}
${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>