aboutsummaryrefslogtreecommitdiffstats
path: root/misc/dahdi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/dahdi/Makefile')
-rw-r--r--misc/dahdi/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index ed61a62cf3fa..3dbadffd4d2e 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -19,8 +19,8 @@ COMMENT= Digium/Asterisk Hardware Device Interface
BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
LIB_DEPENDS= newt.52:${PORTSDIR}/devel/newt
-DAHDI_VERSION= 2.3.0-rc2
-DAHDI_TOOLS_VERSION= 2.3.0
+DAHDI_VERSION= 2.4.0-rc2
+DAHDI_TOOLS_VERSION= 2.4.0-rc1
NO_PACKAGE= Should be in sync with the kernel to work correctly
GNU_CONFIGURE= yes
@@ -29,7 +29,7 @@ CONFIGURE_ENV= WGET=/usr/bin/fetch
USE_LDCONFIG= yes
USE_RC_SUBR= dahdi
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= i386 amd64 sparc64
CONFLICTS= zaptel-[0-9]*
MAN8= dahdi_cfg.8\
@@ -39,8 +39,6 @@ MAN8= dahdi_cfg.8\
dahdi_tool.8\
fxotune.8
-OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
@@ -53,13 +51,6 @@ PLIST_SUB+= X86=""
PLIST_SUB+= X86="@comment "
.endif
-.if defined(WITH_EXPERIMENTAL)
-MAKE_FLAGS+= WITH_EXPERIMENTAL=yes
-PLIST_SUB+= WITH_EXPERIMENTAL=""
-.else
-PLIST_SUB+= WITH_EXPERIMENTAL="@comment "
-.endif
-
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The dahdi port needs FreeBSD kernel source code to compile."; \