aboutsummaryrefslogtreecommitdiffstats
path: root/misc/freebsd-doc-en/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/freebsd-doc-en/Makefile')
-rw-r--r--misc/freebsd-doc-en/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/misc/freebsd-doc-en/Makefile b/misc/freebsd-doc-en/Makefile
index 157a562875f1..72f9c0291de1 100644
--- a/misc/freebsd-doc-en/Makefile
+++ b/misc/freebsd-doc-en/Makefile
@@ -28,7 +28,7 @@
#
PORTNAME= freebsd-doc
-PORTVERSION= 20090417
+PORTVERSION= 20090525
CATEGORIES= misc docs
MASTER_SITES= LOCAL/blackend
PKGNAMEPREFIX?= en-
@@ -53,6 +53,12 @@ DOCBASE?= share/doc/freebsd
PLIST= ${WRKDIR}/pkg-plist
+OPTIONS= HTML "Single HTML file per document" Off \
+ HTML_SPLIT "The default HTML format used on www.FreeBSD.org" On \
+ PDF "PDF format" On \
+ PS "PostScript format" Off \
+ TXT "Plain text" Off
+
.include <bsd.port.pre.mk>
AVAILABLEFORMATS= HTML HTML_SPLIT PDF PS TXT
@@ -83,6 +89,8 @@ BUILD_DEPENDS= docproj-jadetex>=1.17:${PORTSDIR}/textproc/docproj-jadetex
BUILD_DEPENDS= docproj-nojadetex>=1.17:${PORTSDIR}/textproc/docproj-nojadetex
.endif
+MAKE_JOBS_SAFE= yes
+
.for F in ${DOCFORMAT:L}
PLIST_FORMATS+= ${F:L}
.endfor