aboutsummaryrefslogtreecommitdiffstats
path: root/misc/getopt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/getopt/Makefile')
-rw-r--r--misc/getopt/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
index df8956fcd74a..5c4349d7fcc2 100644
--- a/misc/getopt/Makefile
+++ b/misc/getopt/Makefile
@@ -21,18 +21,19 @@ USES= gmake
PORTDOCS= Changelog README
-NLS_CFLAGS= -I${LOCALBASE}/include
NLS_MAKE_ARGS= WITHOUT_GETTEXT=0
NLS_MAKE_ARGS_OFF= WITHOUT_GETTEXT=1
-NLS_LDFLAGS= -L${LOCALBASE}/lib -lintl
-NLS_USES= gettext
+NLS_LDFLAGS= -lintl
+NLS_USES= gettext localbase
post-patch:
@${RM} ${WRKSRC}/gnu/*.o
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/getopt
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/getopt
.include <bsd.port.mk>