aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gnomeuserdocs2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gnomeuserdocs2/Makefile')
-rw-r--r--misc/gnomeuserdocs2/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/gnomeuserdocs2/Makefile b/misc/gnomeuserdocs2/Makefile
new file mode 100644
index 000000000000..663d37ca52bb
--- /dev/null
+++ b/misc/gnomeuserdocs2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnomeuserdocs
+# Date created: 27th February 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomeuserdocs
+PORTVERSION= 1.4.1
+CATEGORIES= misc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= stable/sources/gnome-user-docs
+DISTNAME= gnome-user-docs-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>