aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gnuls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gnuls/Makefile')
-rw-r--r--misc/gnuls/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/misc/gnuls/Makefile b/misc/gnuls/Makefile
index 6d0308d4f7bb..a1d8c8c78b6d 100644
--- a/misc/gnuls/Makefile
+++ b/misc/gnuls/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: GNU colorized `ls'
-# Date created: 06 January 1996
-# Whom: bmc@WillsCreek.COM
-#
+# Created by: bmc@WillsCreek.COM
# $FreeBSD$
-#
PORTNAME= gnuls
-PORTVERSION= 8.12
+PORTVERSION= 8.20
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= coreutils
@@ -15,9 +11,15 @@ DISTNAME= coreutils-${PORTVERSION}
MAINTAINER= bmc@clapper.org
COMMENT= GNU colorized 'ls'
-USE_XZ= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-nls
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" FORCE_UNSAFE_CONFIGURE=1
+CPPFLAGS+= -I${LOCALBASE}/include
+
+USE_XZ= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_PERL5_BUILD=yes # Required for tests and man page generation
+
MAN1= gnuls.1 dircolors.1 dir.1 vdir.1
PLIST_FILES= bin/dir \