aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gpt31/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gpt31/Makefile')
-rw-r--r--misc/gpt31/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/misc/gpt31/Makefile b/misc/gpt31/Makefile
index 81f0e6004db3..b19a031032db 100644
--- a/misc/gpt31/Makefile
+++ b/misc/gpt31/Makefile
@@ -18,8 +18,6 @@ COMMENT= Grid Packaging Tools (used to install Globus)
CONFLICTS= gpt-*
NO_LATEST_LINK= YES
-BROKEN= "Does not build"
-
RUN_DEPENDS+= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
@@ -54,6 +52,12 @@ FIX_VAR_FILES= ${WRKSRC}/packaging_tools/perl/GPT/Localize.pm \
${WRKSRC}/packaging_tools/perl/scripts/gpt-config \
${WRKSRC}/tools/testArchiveTar
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|@@PERL@@|${PERL}|g" ${WRKSRC}/build_gpt
@${REINPLACE_CMD} -e 's|$$gpath/var/lib/perl|/var/db/gpt|g' ${FIX_VAR_FILES}
@@ -63,4 +67,4 @@ do-install:
@cd ${WRKSRC}; \
GPT_LOCATION=${PREFIX} ./build_gpt --with-perl=${PERL}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>