aboutsummaryrefslogtreecommitdiffstats
path: root/misc/k3b-i18n/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/k3b-i18n/Makefile')
-rw-r--r--misc/k3b-i18n/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/k3b-i18n/Makefile b/misc/k3b-i18n/Makefile
new file mode 100644
index 000000000000..bb2f00cbcea1
--- /dev/null
+++ b/misc/k3b-i18n/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: k3b-i18n
+# Date created: Tue Mar 16 00:33:35 CET 2004
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= k3b-i18n
+PORTVERSION= 0.11
+CATEGORIES?= misc kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/-i18n//}
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Localized messages and documentation for K3b
+
+BUILD_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
+
+USE_KDELIBS_VER=3
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-extract:
+ @${TOUCH} ${WRKSRC}/config.h.in
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/xx//' ${WRKSRC}/po/Makefile.in
+
+.include <bsd.port.mk>