aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kdeaddons3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/kdeaddons3/Makefile')
-rw-r--r--misc/kdeaddons3/Makefile49
1 files changed, 27 insertions, 22 deletions
diff --git a/misc/kdeaddons3/Makefile b/misc/kdeaddons3/Makefile
index 12bf7d0f5b5b..95fed83ab1e6 100644
--- a/misc/kdeaddons3/Makefile
+++ b/misc/kdeaddons3/Makefile
@@ -8,31 +8,36 @@
PORTNAME= kdeaddons
PORTVERSION= ${KDE_VERSION}
CATEGORIES?= misc kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
-DIST_SUBDIR= KDE
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
MAINTAINER?= kde@FreeBSD.org
COMMENT= Additional plugins and scripts for some KDE applications
-LIB_DEPENDS+= noatun:${PORTSDIR}/multimedia/kdemultimedia3 \
- kdegames:${PORTSDIR}/games/kdegames3
-
-USE_KDEBASE_VER=3
-PREFIX= ${KDE_PREFIX}
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_SDL= sdl
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-
-post-configure:
- @ ${TOUCH} ${WRKSRC}/configure ${WRKSRC}/config.status \
- ${WRKSRC}/config.h.in
+RUN_DEPENDS= ${ATLANTIKDESIGNER_DEP}:${PORTSDIR}/games/atlantikdesigner \
+ ${KADDRESSBOOKPLUG_DEP}:${PORTSDIR}/misc/kaddressbook-plugins \
+ ${KATEPLUGINS_DEP}:${PORTSDIR}/editors/kate-plugins \
+ ${KFILEPLUGINS_DEP}:${PORTSDIR}/misc/kfile-plugins \
+ ${KICKERAPPLETS_DEP}:${PORTSDIR}/misc/kicker-applets \
+ ${KNEWSTICKERAPP_DEP}:${PORTSDIR}/misc/knewsticker-scripts \
+ ${KONQPLUGINS_DEP}:${PORTSDIR}/misc/konq-plugins \
+ ${KONTACTPLUG_DEP}:${PORTSDIR}/net/kontact-plugins \
+ ${KSIG_DEP}:${PORTSDIR}/misc/ksig \
+ ${NOATUNPLUG_DEP}:${PORTSDIR}/multimedia/noatun-plugins \
+ ${RENAMEDLGPLUG_DEP}:${PORTSDIR}/misc/renamedlgplugins \
+ ${KVIM_DEP}:${PORTSDIR}/editors/vimpart
+
+NO_BUILD= yes
+USE_KDELIBS_VER=3
+
+.if make(package)
+DEPENDS_TARGET="package"
+.endif # .if make(package)
+
+do-install: # empty
+ ${DO_NADA}
+
+.include "${.CURDIR}/Makefile.split"
.include <bsd.port.mk>