aboutsummaryrefslogtreecommitdiffstats
path: root/misc/lesspipe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/lesspipe/Makefile')
-rw-r--r--misc/lesspipe/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/misc/lesspipe/Makefile b/misc/lesspipe/Makefile
index 0f8ee9985756..fa23358b8bbc 100644
--- a/misc/lesspipe/Makefile
+++ b/misc/lesspipe/Makefile
@@ -2,36 +2,25 @@
# $FreeBSD$
PORTNAME= lesspipe
-PORTVERSION= 1.55
-PORTREVISION= 1
+PORTVERSION= 1.83
CATEGORIES= misc
MASTER_SITES= SF
MAINTAINER= slaven@rezic.de
COMMENT= Preprocessor for less
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-
-.if defined(WITH_FANCY)
-BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- rpm:${PORTSDIR}/archivers/rpm4 \
- dpkg:${PORTSDIR}/archivers/dpkg \
- antiword:${PORTSDIR}/textproc/antiword \
- lynx:${PORTSDIR}/www/lynx \
- pdftotext:${PORTSDIR}/graphics/xpdf \
- unrtf:${PORTSDIR}/textproc/unrtf \
- dvi2tty:${PORTSDIR}/print/dvi2tty \
- pstotext:${PORTSDIR}/print/pstotext \
- mp3info:${PORTSDIR}/audio/mp3info \
- cabextract:${PORTSDIR}/archivers/cabextract \
- cdrecord:${PORTSDIR}/sysutils/cdrtools
-.endif
+LICENSE= GPLv2
+
+MY_DEPENDS= bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= ${MY_DEPENDS}
USES= perl5
NO_BUILD= yes
+NO_ARCH= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --default --prefix=${PREFIX}
+CONFIGURE_ARGS= --yes --prefix=${PREFIX}
PLIST_FILES= bin/lesspipe.sh bin/code2color man/man1/lesspipe.1.gz