aboutsummaryrefslogtreecommitdiffstats
path: root/misc/libsupertone/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/libsupertone/Makefile')
-rw-r--r--misc/libsupertone/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/misc/libsupertone/Makefile b/misc/libsupertone/Makefile
new file mode 100644
index 000000000000..b89879c50ab7
--- /dev/null
+++ b/misc/libsupertone/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libsupertone
+# Date created: 26 Jun 2012
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsupertone
+PORTVERSION= 0.0.2
+CATEGORIES= misc
+MASTER_SITES= http://www.soft-switch.org/downloads/unicall/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= A library for supervisory tone generation and detection
+
+LIB_DEPENDS= spandsp.2:${PORTSDIR}/comms/spandsp-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+LICENSE= LGPL21
+
+.include <bsd.port.mk>