aboutsummaryrefslogtreecommitdiffstats
path: root/misc/osinfo-db/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/osinfo-db/Makefile')
-rw-r--r--misc/osinfo-db/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/misc/osinfo-db/Makefile b/misc/osinfo-db/Makefile
new file mode 100644
index 000000000000..73419d13b35b
--- /dev/null
+++ b/misc/osinfo-db/Makefile
@@ -0,0 +1,22 @@
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= osinfo-db
+PORTVERSION= 20160728
+CATEGORIES= misc
+MASTER_SITES= https://fedorahosted.org/releases/l/i/libosinfo/
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Osinfo database files
+
+BUILD_DEPENDS= osinfo-db-import:sysutils/osinfo-db-tools
+
+USES= tar:xz
+NO_BUILD= yes
+
+do-extract: # nada
+
+do-install:
+ osinfo-db-import --root ${STAGEDIR} --system ${DISTDIR}/${DISTFILES}
+
+.include <bsd.port.mk>