aboutsummaryrefslogtreecommitdiffstats
path: root/misc/otter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/otter/Makefile')
-rw-r--r--misc/otter/Makefile41
1 files changed, 23 insertions, 18 deletions
diff --git a/misc/otter/Makefile b/misc/otter/Makefile
index b4a8f2def172..6b9e3214ad3e 100644
--- a/misc/otter/Makefile
+++ b/misc/otter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: otter
-# Date created: 2006-02-04
-# Whom: wollman
-#
+# Created by: Garrett Wollman <wollman@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= otter
PORTVERSION= 3.3f
@@ -12,28 +8,37 @@ CATEGORIES= misc
MASTER_SITES= http://www-unix.mcs.anl.gov/AR/otter/dist33/
MAINTAINER= wollman@FreeBSD.org
-COMMENT= A theorem prover and finite model searcher
+COMMENT= Theorem prover and finite model searcher
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
PROGRAMS= anldp mace2 otter
PORTDOCS= README anldp.pdf mace2.pdf otter33.pdf
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} -e 's|CC=gcc|CC=$$(CC) CFLAGS="$$(CFLAGS)"|g' \
- ${WRKSRC}/Makefile
+# Change "cd foo && $(MAKE)" into "$(MAKE) -C foo"
+ @${REINPLACE_CMD} -E 's,cd (.+) && (\$$\(MAKE\)),\2 -C \1, ; \
+ s,CC=gcc,,' ${WRKSRC}/Makefile
+# Add missing depedencies for install targets
+ @${REINPLACE_CMD} -e 's,^install:,& otter,' \
+ ${WRKSRC}/source/Makefile
+ @${REINPLACE_CMD} -e 's,^install:,& mace2 anldp,' \
+ ${WRKSRC}/mace2/Makefile
do-install:
-.for prog in ${PROGRAMS}
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${prog} ${PREFIX}/bin
-.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/documents/${doc} ${DOCSDIR}
-.endfor
+ ${INSTALL_PROGRAM} ${PROGRAMS:S,^,${WRKSRC}/bin/,} ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/documents/,} ${DOCSDIR}
.endif
- ${MKDIR} ${EXAMPLESDIR}
- ${MKDIR} ${PREFIX}/share/examples/mace2
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR} ${PREFIX}/share/examples/mace2
(cd ${WRKSRC}/examples; ${PAX} -rw . ${EXAMPLESDIR})
(cd ${WRKSRC}/examples-mace2; ${PAX} -rw . ${PREFIX}/share/examples/mace2)
+.endif
.include <bsd.port.mk>