aboutsummaryrefslogtreecommitdiffstats
path: root/misc/rump/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/rump/Makefile')
-rw-r--r--misc/rump/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/misc/rump/Makefile b/misc/rump/Makefile
index 5cfd4f282fe8..a704f850aae7 100644
--- a/misc/rump/Makefile
+++ b/misc/rump/Makefile
@@ -18,14 +18,17 @@ USE_GITHUB= yes
GH_ACCOUNT= rumpkernel
GH_PROJECT= buildrump.sh
GH_TAGNAME= b914579
-GH_TUPLE= rumpkernel:src-netbsd:82f3a69:netbsd/src
+GH_TUPLE= rumpkernel:src-netbsd:82f3a69:netbsd/src
USE_LDCONFIG= yes
-USE_GCC= any
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 1100121
+CFLAGS+= -Wno-address-of-packed-member
+.endif
+
do-build:
- cd ${WRKSRC}; ${SETENV} CC=${CC} AR=${AR} NM=${NM} OBJCOPY=${OBJCOPY} ./buildrump.sh -r fullbuild
+ cd ${WRKSRC}; ${SETENV} CC=${CC} AR=${AR} NM=${NM} OBJCOPY=${OBJCOPY} ./buildrump.sh -F CFLAGS="${CFLAGS}" -r fullbuild
do-install:
cd ${WRKSRC}/rump; ${PAX} -wr lib include ${STAGEDIR}${PREFIX}/