aboutsummaryrefslogtreecommitdiffstats
path: root/misc/seizedesktop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/seizedesktop/Makefile')
-rw-r--r--misc/seizedesktop/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/misc/seizedesktop/Makefile b/misc/seizedesktop/Makefile
new file mode 100644
index 000000000000..ceee495fc142
--- /dev/null
+++ b/misc/seizedesktop/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: JDE's SeizeDesktop
+# Version required: 0.1a
+# Date created: 25 March 1999
+# Whom: KIRIYAMA Kazuhiko <kiri@pis.toba-cmt.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= SeizeDesktop-0.1a
+PKGNAME= ${LANGPREFIX}seizedesktop-0.1a
+CATEGORIES= ${CATEGORY_LIST}
+MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/JDE/dist/
+
+MAINTAINER= kiri@pis.toba-cmt.ac.jp
+
+RUN_DEPENDS= ${RUN_DEP_LIST}
+
+EXTRACT_ONLY= # extracted directly in install target
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_X_PREFIX= yes
+SCRIPTS_ENV= LANG=C LN=${LN} PERL=${PERL} LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
+
+# This port is for both x11-toolkits/seizedesktop and japanese/seizedesktop.
+# But x11-toolkits/seizedesktop and japanese/seizedesktop are mutually exclusive and
+# SHOULD NOT BE INSTALLED SIMULTANEOUSLY!
+TKSTEPVERSION= 8.0
+LANGUAGE?=
+.if (${LANGUAGE} == "Japanese")
+LANGPREFIX= ja-
+CATEGORY_LIST= misc windowmaker tkstep80 japanese
+RUN_DEP_LIST= ${LOCALBASE}/lib/Img1.2/libimg12.so.1:${PORTSDIR}/japanese/libimg \
+ ${LOCALBASE}/lib/tkstep8.0jp/tkstep.tcl:${PORTSDIR}/japanese/tkstep80
+.else
+CATEGORY_LIST= x11-toolkits windowmaker tkstep80
+RUN_DEP_LIST= ${LOCALBASE}/lib/Img1.2/libimg12.so.1:${PORTSDIR}/graphics/libimg \
+ ${LOCALBASE}/share/tkstep8.0/tkstep.tcl:${PORTSDIR}/x11-toolkits/tkstep80
+.endif
+
+do-install:
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTNAME}.tar.gz \
+ ${EXTRACT_AFTER_ARGS} -C ${PREFIX}
+
+.include <bsd.port.mk>