aboutsummaryrefslogtreecommitdiffstats
path: root/misc/termatrix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/termatrix/Makefile')
-rw-r--r--misc/termatrix/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/termatrix/Makefile b/misc/termatrix/Makefile
new file mode 100644
index 000000000000..e4fb12749aec
--- /dev/null
+++ b/misc/termatrix/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: termatrix
+# Date created: 2007/07/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= termatrix
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= LOCAL/chinsan \
+ http://lightless.org/files/
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Emulates Matrix terminal's "green tears" effect
+
+PLIST_FILES= bin/termatrix
+PORTDOCS= README
+
+do-build:
+ ${CC} ${CFLAGS} ${CPPFLAGS} -o ${WRKSRC}/termatrix \
+ ${WRKSRC}/termatrix.c ${LDFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/termatrix ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>