aboutsummaryrefslogtreecommitdiffstats
path: root/misc/xiphos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xiphos/Makefile')
-rw-r--r--misc/xiphos/Makefile37
1 files changed, 19 insertions, 18 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 9f0321f7586f..04d2d0dfeed4 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -5,31 +5,32 @@
# $FreeBSD$
#
-PORTNAME= gnomesword
-PORTVERSION= 0.7.8
-PORTREVISION= 1
-CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= gnomesword
+PORTVERSION= 0.7.9
+CATEGORIES= misc gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@freebsd.org
-COMMENT= A bible interface utilizing the sword framework
+MAINTAINER= ports@FreBSD.org
+COMMENT= A bible interface utilizing the sword framework
-LIB_DEPENDS= sword.1:${PORTSDIR}/misc/sword
-BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS= sword.1:${PORTSDIR}/misc/sword
+RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
-USE_GNOME= gal gnomehack gnomeprefix gtkhtml
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-DOC_FILES= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+USE_X_PREFIX= yes
+USE_GNOME= gal gnomehack gnomeprefix gtkhtml
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DUSE_GTKHTML1" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-install:
-.ifndef(NOPORTDOCS)
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for file in AUTHORS ChangeLog INSTALL NEWS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif