aboutsummaryrefslogtreecommitdiffstats
path: root/misc/xpns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xpns/Makefile')
-rw-r--r--misc/xpns/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/misc/xpns/Makefile b/misc/xpns/Makefile
new file mode 100644
index 000000000000..861ff92194ed
--- /dev/null
+++ b/misc/xpns/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xpns
+# Version required: 1.0
+# Date created: 6 Apr 97
+# Whom: Pedro Giffuni <pgiffuni@fps.biblos.unal.edu.co>
+#
+# $Id: Makefile,v 1.2 1997/03/28 02:35:44 obrien Exp $
+#
+
+DISTNAME= pns_source
+PKGNAME= xpns-1.0
+CATEGORIES= misc cad
+MASTER_SITES= ftp://ftp.informatik.uni-stuttgart.de/pub/petri-nets/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= pgiffuni@fps.biblos.unal.edu.co
+
+USE_X11= yes
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile
+ALL_TARGET= pns
+
+do-install:
+ $(MKDIR) $(PREFIX)/lib/xpns
+ $(INSTALL_PROGRAM) $(WRKSRC)/pns $(PREFIX)/lib/xpns/
+ $(INSTALL_DATA) $(WRKSRC)/pns.hlp $(PREFIX)/lib/xpns/
+ $(INSTALL_DATA) $(WRKSRC)/pns.shell $(PREFIX)/lib/xpns/
+ $(INSTALL_SCRIPT) $(WRKSRC)/xpns $(PREFIX)/bin/xpns
+
+post-install:
+.if !defined(NOPORTDOCS)
+ $(MKDIR) $(PREFIX)/share/doc/xpns
+ $(CP) $(WRKSRC)/*.net $(PREFIX)/share/doc/xpns/
+.endif
+
+.include <bsd.port.mk>