aboutsummaryrefslogtreecommitdiffstats
path: root/misc/zaptel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/zaptel/Makefile')
-rw-r--r--misc/zaptel/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/misc/zaptel/Makefile b/misc/zaptel/Makefile
index 89be1a4e4f92..08d2dd1dbda3 100644
--- a/misc/zaptel/Makefile
+++ b/misc/zaptel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zaptel
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.6
CATEGORIES= misc kld
MASTER_SITES= http://www.pbxpress.com/~gonzo/
DISTNAME= ${PORTNAME}-bsd-${PORTVERSION}
@@ -18,7 +18,7 @@ LIB_DEPENDS= newt.51:${PORTSDIR}/devel/newt
NO_PACKAGE= Should be in sync with the kernel to work correctly
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
MAKE_ENV= KMODDIR=${PREFIX}/lib/zaptel
SUB_FILES= pkg-message
@@ -26,6 +26,13 @@ USE_RC_SUBR= zaptel
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64"
+PLIST_SUB+= WITH_TAU32="@comment "
+.else
+PLIST_SUB+= WITH_TAU32="@comment "
+MAKE_ARGS+= WITH_TAU32="yes"
+.endif
+
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The zaptel port needs FreeBSD kernel source code to compile."; \