aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/gkx86info2/Makefile2
-rw-r--r--misc/gnome-user-docs/Makefile8
-rw-r--r--misc/linm/Makefile2
-rw-r--r--misc/mc-light/Makefile2
-rw-r--r--misc/mc/Makefile8
-rw-r--r--misc/metalink-tools/Makefile8
-rw-r--r--misc/salias/Makefile2
-rw-r--r--misc/shared-mime-info/Makefile3
-rw-r--r--misc/xdelta/Makefile2
-rw-r--r--misc/xfce4-weather-plugin/Makefile2
10 files changed, 13 insertions, 26 deletions
diff --git a/misc/gkx86info2/Makefile b/misc/gkx86info2/Makefile
index e33286a6036d..40207311f868 100644
--- a/misc/gkx86info2/Makefile
+++ b/misc/gkx86info2/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
ONLY_FOR_ARCHS= i386 amd64
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/gkx86info${PORTVERSION}
diff --git a/misc/gnome-user-docs/Makefile b/misc/gnome-user-docs/Makefile
index e3a0e3796cd6..25a1aec54cc6 100644
--- a/misc/gnome-user-docs/Makefile
+++ b/misc/gnome-user-docs/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnomeuserdocs2
-# Date created: 07 July 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/misc/gnome-user-docs/Makefile,v 1.62 2010/09/30 06:07:30 kwm Exp $
-#
PORTNAME= gnome-user-docs
PORTVERSION= 2.32.0
@@ -18,8 +14,8 @@ COMMENT= GNOME 2 users guide
BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
+USES= pkgconfig
USE_BZIP2= yes
-USE_PKGCONFIG= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
diff --git a/misc/linm/Makefile b/misc/linm/Makefile
index f81b95073065..36791bab1fb0 100644
--- a/misc/linm/Makefile
+++ b/misc/linm/Makefile
@@ -12,9 +12,9 @@ DISTNAME= linm_${LINM_VER}-1
MAINTAINER= ports@FreeBSD.org
COMMENT= Clone of Mdir, mc-style terminal file manager
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_ICONV= yes
-USE_PKGCONFIG= yes
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/misc/mc-light/Makefile b/misc/mc-light/Makefile
index c9a22a2e6839..0e112e91be22 100644
--- a/misc/mc-light/Makefile
+++ b/misc/mc-light/Makefile
@@ -19,9 +19,9 @@ OPTIONS_DEFINE= NLS SUBSHELL MC_IN_MC
SUBSHELL_DESC= Build with subshell support (only for bash!)
MC_IN_MC_DESC= Allow run mc inside mc (useful for mcedit)
+USES= pkgconfig
USE_GMAKE= yes
USE_ICONV= yes
-USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-included-slang \
--with-gettext \
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index d1871cbbf937..53a305005f53 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mc
-# Date created: 15 Jul 1995
-# Whom: torstenb@FreeBSD.org
-#
+# Created by: torstenb@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= mc
PORTVERSION= 4.8.1.7
@@ -22,9 +18,9 @@ LICENSE= GPLv3
CONFLICTS= mc-light-4*
+USES= pkgconfig
USE_GMAKE= yes
USE_GNOME= glib20
-USE_PKGCONFIG= yes
USE_PERL5= yes
USE_XZ= yes
GNU_CONFIGURE= yes
diff --git a/misc/metalink-tools/Makefile b/misc/metalink-tools/Makefile
index deccf4912de9..1a9257b4ed04 100644
--- a/misc/metalink-tools/Makefile
+++ b/misc/metalink-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Metalink tools
-# Date created: Sun 10 Aug 2008 04:22:51 UTC
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= metalink
PORTVERSION= 0.3.6
@@ -25,7 +21,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GNOME= glib20
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
+USES= pkgconfig
CONFIGURE_ENV+= AWK="${AWK}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/misc/salias/Makefile b/misc/salias/Makefile
index f3abbafad473..3ecc85bbbb66 100644
--- a/misc/salias/Makefile
+++ b/misc/salias/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/C%20${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= CLI tool to alias arguments of other programs
+USES= pkgconfig
USE_BZIP2= yes
USE_GNOME= glib20
-USE_PKGCONFIG= build
GNU_CONFIGURE= yes
MAN1= salias.1
diff --git a/misc/shared-mime-info/Makefile b/misc/shared-mime-info/Makefile
index 12b26daad12a..1114b7e2e455 100644
--- a/misc/shared-mime-info/Makefile
+++ b/misc/shared-mime-info/Makefile
@@ -16,8 +16,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-update-mimedb
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
-USES= pathfix
+USES= pathfix pkgconfig
USE_GNOME= glib20 libxml2 intltool intlhack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/misc/xdelta/Makefile b/misc/xdelta/Makefile
index 854f0ea9b9c2..c5fc4ebb6bcc 100644
--- a/misc/xdelta/Makefile
+++ b/misc/xdelta/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= ports@FreeBSD.org
COMMENT= A diff/patch utility for binary files
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_GNOME= glib20
-USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/misc/xfce4-weather-plugin/Makefile b/misc/xfce4-weather-plugin/Makefile
index e84b9fffa2a1..0769d991d23a 100644
--- a/misc/xfce4-weather-plugin/Makefile
+++ b/misc/xfce4-weather-plugin/Makefile
@@ -16,12 +16,12 @@ LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+USES= pkgconfig
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack glib20 gtk20 intltool intlhack libxml2
USE_XFCE= configenv libmenu libutil panel
-USE_PKGCONFIG= build
OPTIONS_DEFINE= UPOWER
UPOWER_DESC= Power state support