aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/mc/Makefile2
-rw-r--r--misc/mc/files/patch-lib__tty__win.c18
2 files changed, 10 insertions, 10 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index e7b45738ac4c..04a3db851b7e 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mc
PORTVERSION= 4.8.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc shells
MASTER_SITES= http://ftp.midnight-commander.org/ \
http://ftp.osuosl.org/pub/midnightcommander/ \
diff --git a/misc/mc/files/patch-lib__tty__win.c b/misc/mc/files/patch-lib__tty__win.c
index 4e497178418b..7892aa154629 100644
--- a/misc/mc/files/patch-lib__tty__win.c
+++ b/misc/mc/files/patch-lib__tty__win.c
@@ -1,14 +1,14 @@
--- lib/tty/win.c.orig 2014-09-02 09:23:58 UTC
+++ lib/tty/win.c
-+@@ -95,7 +95,7 @@
-+ void
-+ do_enter_ca_mode (void)
-+ {
-+- if (mc_global.tty.xterm_flag && smcup != NULL)
-++ if (mc_global.tty.xterm_flag)
-+ {
-+ fprintf (stdout, /* ESC_STR ")0" */ ESC_STR "7" ESC_STR "[?47h");
-+ fflush (stdout);
+@@ -95,7 +95,7 @@
+ void
+ do_enter_ca_mode (void)
+ {
+- if (mc_global.tty.xterm_flag && smcup != NULL)
++ if (mc_global.tty.xterm_flag)
+ {
+ fprintf (stdout, /* ESC_STR ")0" */ ESC_STR "7" ESC_STR "[?47h");
+ fflush (stdout);
@@ -107,7 +107,7 @@
void
do_exit_ca_mode (void)