aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/py-pexpect/Makefile4
-rw-r--r--misc/py-pexpect/distinfo5
-rw-r--r--misc/py-pexpect/files/patch-pexpect-__init__.py11
-rw-r--r--misc/py-pexpect/pkg-descr2
4 files changed, 7 insertions, 15 deletions
diff --git a/misc/py-pexpect/Makefile b/misc/py-pexpect/Makefile
index ca979dc8986a..cda82728b1f1 100644
--- a/misc/py-pexpect/Makefile
+++ b/misc/py-pexpect/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pexpect
-PORTVERSION= 3.3
+PORTVERSION= 4.2.1
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,6 +12,8 @@ COMMENT= Pure Python Expect-like module
LICENSE= ISCL
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ptyprocess>=0:sysutils/py-ptyprocess
+
USES= python
USE_PYTHON= distutils autoplist
diff --git a/misc/py-pexpect/distinfo b/misc/py-pexpect/distinfo
index cbb5facaa4f5..44ffc735325f 100644
--- a/misc/py-pexpect/distinfo
+++ b/misc/py-pexpect/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pexpect-3.3.tar.gz) = dfea618d43e83cfff21504f18f98019ba520f330e4142e5185ef7c73527de5ba
-SIZE (pexpect-3.3.tar.gz) = 132330
+TIMESTAMP = 1487042189
+SHA256 (pexpect-4.2.1.tar.gz) = 3d132465a75b57aa818341c6521392a06cc660feb3988d7f1074f39bd23c9a92
+SIZE (pexpect-4.2.1.tar.gz) = 143980
diff --git a/misc/py-pexpect/files/patch-pexpect-__init__.py b/misc/py-pexpect/files/patch-pexpect-__init__.py
deleted file mode 100644
index 9eaab85a9ec8..000000000000
--- a/misc/py-pexpect/files/patch-pexpect-__init__.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- pexpect/__init__.py.orig 2014-04-15 03:31:01.000000000 +0200
-+++ pexpect/__init__.py 2014-05-12 14:41:21.690335992 +0200
-@@ -1562,7 +1562,7 @@
- # termios.TIOCSWINSZ to be truncated. There was a hack here to work
- # around this, but it caused problems with newer platforms so has been
- # removed. For details see https://github.com/pexpect/pexpect/issues/39
-- TIOCSWINSZ = getattr(termios, 'TIOCSWINSZ', -2146929561)
-+ TIOCSWINSZ = getattr(termios, 'TIOCSWINSZ', 2148037735)
- # Note, assume ws_xpixel and ws_ypixel are zero.
- s = struct.pack('HHHH', rows, cols, 0, 0)
- fcntl.ioctl(self.fileno(), TIOCSWINSZ, s)
diff --git a/misc/py-pexpect/pkg-descr b/misc/py-pexpect/pkg-descr
index 8ed5c3f67604..e64c7a299b17 100644
--- a/misc/py-pexpect/pkg-descr
+++ b/misc/py-pexpect/pkg-descr
@@ -11,4 +11,4 @@ software package installations on different servers. It can be used for
automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
Pexpect is pure Python. The Pexpect interface was designed to be easy to use.
-WWW: http://pexpect.sourceforge.net
+WWW: https://pexpect.readthedocs.io/