aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/clex/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/misc/clex/Makefile b/misc/clex/Makefile
index d5ed14ee2c64..9014b2b8798c 100644
--- a/misc/clex/Makefile
+++ b/misc/clex/Makefile
@@ -18,11 +18,13 @@ USES= ncurses gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/clex bin/cfg-clex bin/kbd-test
+PLIST_FILES= bin/clex bin/cfg-clex bin/kbd-test \
+ man/man1/cfg-clex.1.gz \
+ man/man1/clex.1.gz \
+ man/man1/kbd-test.1.gz
+
PORTDOCS= AUTHORS ChangeLog README
-MAN1= clex.1 cfg-clex.1 kbd-test.1
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '18s,^,#include <stdio.h>,' \
${WRKSRC}/src/preview.c
@@ -33,8 +35,8 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>