aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/kdeaddons/Makefile46
-rw-r--r--misc/kdeaddons/distinfo2
-rw-r--r--misc/kdeaddons/pkg-plist60
-rw-r--r--misc/kdeaddons3/Makefile46
-rw-r--r--misc/kdeaddons3/distinfo2
-rw-r--r--misc/kdeaddons3/pkg-plist60
-rw-r--r--misc/kdeutils2/Makefile24
-rw-r--r--misc/kdeutils2/distinfo2
-rw-r--r--misc/kdeutils2/files/patch-portable.cpp20
-rw-r--r--misc/kdeutils2/pkg-plist3
-rw-r--r--misc/kdeutils3/Makefile24
-rw-r--r--misc/kdeutils3/distinfo2
-rw-r--r--misc/kdeutils3/files/patch-portable.cpp20
-rw-r--r--misc/kdeutils3/pkg-plist3
-rw-r--r--misc/kdeutils4/Makefile24
-rw-r--r--misc/kdeutils4/distinfo2
-rw-r--r--misc/kdeutils4/files/patch-portable.cpp20
-rw-r--r--misc/kdeutils4/pkg-plist3
18 files changed, 232 insertions, 131 deletions
diff --git a/misc/kdeaddons/Makefile b/misc/kdeaddons/Makefile
index 26fe58557c84..18fe7500dff1 100644
--- a/misc/kdeaddons/Makefile
+++ b/misc/kdeaddons/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeaddons
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,30 +14,40 @@ DIST_SUBDIR= KDE
MAINTAINER?= ports@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2 \
+ SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+WITH_SDL= yes
USE_KDEBASE_VER=2
-LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
PLIST_SUB+= RM=${RM}
+CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/SDL11/SDL.h)
-WITH_SDL= yes
-.endif
-
-.if defined(WITH_SDL) && ${WITH_SDL} == yes
-LIB_DEPENDS+= SDL-1.1.3:${PORTSDIR}/devel/sdl12
-CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
-PLIST_SUB+= SDL=""
-.else
-PLIST_SUB+= SDL="@comment "
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with SDL support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SDL=yes\""
- @${ECHO_MSG}
-.endif
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+ find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ "s@sdl-config@${LOCALBASE}/bin/sdl11-config@g"
.include <bsd.port.post.mk>
diff --git a/misc/kdeaddons/distinfo b/misc/kdeaddons/distinfo
index 54bc41edca3c..40c40c31dea5 100644
--- a/misc/kdeaddons/distinfo
+++ b/misc/kdeaddons/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeaddons-2.2.1.tar.bz2) = 034f35ed3cd575b65f8ccc6110590d20
+MD5 (KDE/kdeaddons-2.2.2.tar.bz2) = 9392da0992f4aede5f6a86840e47fef6
diff --git a/misc/kdeaddons/pkg-plist b/misc/kdeaddons/pkg-plist
index 3eca8d5c45a4..de49b3f8b00c 100644
--- a/misc/kdeaddons/pkg-plist
+++ b/misc/kdeaddons/pkg-plist
@@ -1,11 +1,7 @@
-@unexec %%RM%% -f %D/lib/libkolourpicker.so
-@unexec %%RM%% -f %D/lib/libktimemon.so
-@unexec %%RM%% -f %D/share/doc/HTML/en/kate-plugins/common
-@unexec %%RM%% -f %D/share/doc/HTML/en/kicker-applets/common
bin/dcop_kate
-%%SDL%%bin/noatunsynaescope.bin
-%%SDL%%bin/noatuntippecanoe.bin
-%%SDL%%bin/noatuntyler.bin
+bin/noatunsynaescope.bin
+bin/noatuntippecanoe.bin
+bin/noatuntyler.bin
bin/testor
lib/kde2/libbabelfishplugin.la
lib/kde2/libbabelfishplugin.so
@@ -41,30 +37,30 @@ lib/libkolourpicker.so.1
lib/libktimemon.la
lib/libktimemon.so
lib/libktimemon.so.1
-%%SDL%%lib/libnoatunblurscope.la
-%%SDL%%lib/libnoatunblurscope.so
+lib/libnoatunblurscope.la
+lib/libnoatunblurscope.so
lib/libnoatunluckytag.la
lib/libnoatunluckytag.so
lib/libnoatunmadness.la
lib/libnoatunmadness.so
-%%SDL%%lib/libnoatunsynaescope.la
-%%SDL%%lib/libnoatunsynaescope.so
-%%SDL%%lib/libnoatuntippecanoe.la
-%%SDL%%lib/libnoatuntippecanoe.so
-%%SDL%%lib/libnoatuntyler.la
-%%SDL%%lib/libnoatuntyler.so
+lib/libnoatunsynaescope.la
+lib/libnoatunsynaescope.so
+lib/libnoatuntippecanoe.la
+lib/libnoatuntippecanoe.so
+lib/libnoatuntyler.la
+lib/libnoatuntyler.so
lib/libnoatunwakeup.la
lib/libnoatunwakeup.so
-share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/katehtmltools.desktop
-share/apps/kate/plugins/kateinsertcommand/ui.rc
+share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/kateinsertcommand.desktop
-share/apps/kate/plugins/kateopenheader/ui.rc
+share/apps/kate/plugins/kateinsertcommand/ui.rc
share/apps/kate/plugins/kateopenheader.desktop
-share/apps/kate/plugins/kateprojectmanager/ui.rc
+share/apps/kate/plugins/kateopenheader/ui.rc
share/apps/kate/plugins/kateprojectmanager.desktop
-share/apps/kate/plugins/katetextfilter/ui.rc
+share/apps/kate/plugins/kateprojectmanager/ui.rc
share/apps/kate/plugins/katetextfilter.desktop
+share/apps/kate/plugins/katetextfilter/ui.rc
share/apps/khtml/kpartplugins/khtmlsettingsplugin.rc
share/apps/khtml/kpartplugins/plugin_babelfish.rc
share/apps/khtml/kpartplugins/plugin_domtreeviewer.rc
@@ -84,13 +80,13 @@ share/apps/konqiconview/kpartplugins/dirfilterplugin.rc
share/apps/konqiconview/kpartplugins/kimgalleryplugin.rc
share/apps/konqlistview/kpartplugins/dirfilterplugin.rc
share/apps/konqlistview/kpartplugins/kimgalleryplugin.rc
-%%SDL%%share/apps/noatun/blurscope.plugin
+share/apps/noatun/blurscope.plugin
share/apps/noatun/luckytag.plugin
share/apps/noatun/madness.plugin
-%%SDL%%share/apps/noatun/synaescope.plugin
-%%SDL%%share/apps/noatun/tippecanoe.plugin
-%%SDL%%share/apps/noatun/tyler.plugin
-%%SDL%%share/apps/noatun/tylerstates
+share/apps/noatun/synaescope.plugin
+share/apps/noatun/tippecanoe.plugin
+share/apps/noatun/tyler.plugin
+share/apps/noatun/tylerstates
share/apps/noatun/wakeup.plugin
share/doc/HTML/en/kate-plugins/common
share/doc/HTML/en/kate-plugins/helloworld.docbook
@@ -124,28 +120,14 @@ share/icons/locolor/16x16/apps/ktimemon.png
share/icons/locolor/32x32/apps/ktimemon.png
share/mimelnk/application/x-webarchive.desktop
share/services/webarchivethumbnail.desktop
-@dirrm share/services
-@dirrm share/mimelnk/application
-@dirrm share/icons/locolor/32x32/apps
-@dirrm share/icons/locolor/16x16/apps
-@dirrm share/icons/hicolor/22x22/actions
-@dirrm share/icons/hicolor/16x16/actions
@dirrm share/doc/HTML/en/kicker-applets
@dirrm share/doc/HTML/en/kate-plugins
-@dirrm share/doc/HTML/en
-@dirrm share/apps/noatun
-@dirrm share/apps/konqlistview/kpartplugins
-@dirrm share/apps/konqiconview/kpartplugins
@dirrm share/apps/knewsticker/scripts
@dirrm share/apps/knewsticker
-@dirrm share/apps/kicker/applets
@dirrm share/apps/khtml/kpartplugins
-@dirrm share/apps/khtml
@dirrm share/apps/kate/plugins/katetextfilter
@dirrm share/apps/kate/plugins/kateprojectmanager
@dirrm share/apps/kate/plugins/kateopenheader
@dirrm share/apps/kate/plugins/kateinsertcommand
@dirrm share/apps/kate/plugins/katehtmltools
@dirrm share/apps/kate/plugins
-@dirrm share/apps/kate
-@dirrm lib/kde2
diff --git a/misc/kdeaddons3/Makefile b/misc/kdeaddons3/Makefile
index 26fe58557c84..18fe7500dff1 100644
--- a/misc/kdeaddons3/Makefile
+++ b/misc/kdeaddons3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeaddons
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,30 +14,40 @@ DIST_SUBDIR= KDE
MAINTAINER?= ports@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2 \
+ SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+WITH_SDL= yes
USE_KDEBASE_VER=2
-LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
PLIST_SUB+= RM=${RM}
+CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/SDL11/SDL.h)
-WITH_SDL= yes
-.endif
-
-.if defined(WITH_SDL) && ${WITH_SDL} == yes
-LIB_DEPENDS+= SDL-1.1.3:${PORTSDIR}/devel/sdl12
-CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
-PLIST_SUB+= SDL=""
-.else
-PLIST_SUB+= SDL="@comment "
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with SDL support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SDL=yes\""
- @${ECHO_MSG}
-.endif
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+ find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ "s@sdl-config@${LOCALBASE}/bin/sdl11-config@g"
.include <bsd.port.post.mk>
diff --git a/misc/kdeaddons3/distinfo b/misc/kdeaddons3/distinfo
index 54bc41edca3c..40c40c31dea5 100644
--- a/misc/kdeaddons3/distinfo
+++ b/misc/kdeaddons3/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeaddons-2.2.1.tar.bz2) = 034f35ed3cd575b65f8ccc6110590d20
+MD5 (KDE/kdeaddons-2.2.2.tar.bz2) = 9392da0992f4aede5f6a86840e47fef6
diff --git a/misc/kdeaddons3/pkg-plist b/misc/kdeaddons3/pkg-plist
index 3eca8d5c45a4..de49b3f8b00c 100644
--- a/misc/kdeaddons3/pkg-plist
+++ b/misc/kdeaddons3/pkg-plist
@@ -1,11 +1,7 @@
-@unexec %%RM%% -f %D/lib/libkolourpicker.so
-@unexec %%RM%% -f %D/lib/libktimemon.so
-@unexec %%RM%% -f %D/share/doc/HTML/en/kate-plugins/common
-@unexec %%RM%% -f %D/share/doc/HTML/en/kicker-applets/common
bin/dcop_kate
-%%SDL%%bin/noatunsynaescope.bin
-%%SDL%%bin/noatuntippecanoe.bin
-%%SDL%%bin/noatuntyler.bin
+bin/noatunsynaescope.bin
+bin/noatuntippecanoe.bin
+bin/noatuntyler.bin
bin/testor
lib/kde2/libbabelfishplugin.la
lib/kde2/libbabelfishplugin.so
@@ -41,30 +37,30 @@ lib/libkolourpicker.so.1
lib/libktimemon.la
lib/libktimemon.so
lib/libktimemon.so.1
-%%SDL%%lib/libnoatunblurscope.la
-%%SDL%%lib/libnoatunblurscope.so
+lib/libnoatunblurscope.la
+lib/libnoatunblurscope.so
lib/libnoatunluckytag.la
lib/libnoatunluckytag.so
lib/libnoatunmadness.la
lib/libnoatunmadness.so
-%%SDL%%lib/libnoatunsynaescope.la
-%%SDL%%lib/libnoatunsynaescope.so
-%%SDL%%lib/libnoatuntippecanoe.la
-%%SDL%%lib/libnoatuntippecanoe.so
-%%SDL%%lib/libnoatuntyler.la
-%%SDL%%lib/libnoatuntyler.so
+lib/libnoatunsynaescope.la
+lib/libnoatunsynaescope.so
+lib/libnoatuntippecanoe.la
+lib/libnoatuntippecanoe.so
+lib/libnoatuntyler.la
+lib/libnoatuntyler.so
lib/libnoatunwakeup.la
lib/libnoatunwakeup.so
-share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/katehtmltools.desktop
-share/apps/kate/plugins/kateinsertcommand/ui.rc
+share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/kateinsertcommand.desktop
-share/apps/kate/plugins/kateopenheader/ui.rc
+share/apps/kate/plugins/kateinsertcommand/ui.rc
share/apps/kate/plugins/kateopenheader.desktop
-share/apps/kate/plugins/kateprojectmanager/ui.rc
+share/apps/kate/plugins/kateopenheader/ui.rc
share/apps/kate/plugins/kateprojectmanager.desktop
-share/apps/kate/plugins/katetextfilter/ui.rc
+share/apps/kate/plugins/kateprojectmanager/ui.rc
share/apps/kate/plugins/katetextfilter.desktop
+share/apps/kate/plugins/katetextfilter/ui.rc
share/apps/khtml/kpartplugins/khtmlsettingsplugin.rc
share/apps/khtml/kpartplugins/plugin_babelfish.rc
share/apps/khtml/kpartplugins/plugin_domtreeviewer.rc
@@ -84,13 +80,13 @@ share/apps/konqiconview/kpartplugins/dirfilterplugin.rc
share/apps/konqiconview/kpartplugins/kimgalleryplugin.rc
share/apps/konqlistview/kpartplugins/dirfilterplugin.rc
share/apps/konqlistview/kpartplugins/kimgalleryplugin.rc
-%%SDL%%share/apps/noatun/blurscope.plugin
+share/apps/noatun/blurscope.plugin
share/apps/noatun/luckytag.plugin
share/apps/noatun/madness.plugin
-%%SDL%%share/apps/noatun/synaescope.plugin
-%%SDL%%share/apps/noatun/tippecanoe.plugin
-%%SDL%%share/apps/noatun/tyler.plugin
-%%SDL%%share/apps/noatun/tylerstates
+share/apps/noatun/synaescope.plugin
+share/apps/noatun/tippecanoe.plugin
+share/apps/noatun/tyler.plugin
+share/apps/noatun/tylerstates
share/apps/noatun/wakeup.plugin
share/doc/HTML/en/kate-plugins/common
share/doc/HTML/en/kate-plugins/helloworld.docbook
@@ -124,28 +120,14 @@ share/icons/locolor/16x16/apps/ktimemon.png
share/icons/locolor/32x32/apps/ktimemon.png
share/mimelnk/application/x-webarchive.desktop
share/services/webarchivethumbnail.desktop
-@dirrm share/services
-@dirrm share/mimelnk/application
-@dirrm share/icons/locolor/32x32/apps
-@dirrm share/icons/locolor/16x16/apps
-@dirrm share/icons/hicolor/22x22/actions
-@dirrm share/icons/hicolor/16x16/actions
@dirrm share/doc/HTML/en/kicker-applets
@dirrm share/doc/HTML/en/kate-plugins
-@dirrm share/doc/HTML/en
-@dirrm share/apps/noatun
-@dirrm share/apps/konqlistview/kpartplugins
-@dirrm share/apps/konqiconview/kpartplugins
@dirrm share/apps/knewsticker/scripts
@dirrm share/apps/knewsticker
-@dirrm share/apps/kicker/applets
@dirrm share/apps/khtml/kpartplugins
-@dirrm share/apps/khtml
@dirrm share/apps/kate/plugins/katetextfilter
@dirrm share/apps/kate/plugins/kateprojectmanager
@dirrm share/apps/kate/plugins/kateopenheader
@dirrm share/apps/kate/plugins/kateinsertcommand
@dirrm share/apps/kate/plugins/katehtmltools
@dirrm share/apps/kate/plugins
-@dirrm share/apps/kate
-@dirrm lib/kde2
diff --git a/misc/kdeutils2/Makefile b/misc/kdeutils2/Makefile
index 42d7e7fffe93..d1ab1df6523f 100644
--- a/misc/kdeutils2/Makefile
+++ b/misc/kdeutils2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeutils
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,11 +14,33 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+
.include <bsd.port.mk>
diff --git a/misc/kdeutils2/distinfo b/misc/kdeutils2/distinfo
index 562818721e98..2a396fa164aa 100644
--- a/misc/kdeutils2/distinfo
+++ b/misc/kdeutils2/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeutils-2.2.1.tar.bz2) = a511f6be6949d5b1c2f943f3f9ce27a5
+MD5 (KDE/kdeutils-2.2.2.tar.bz2) = 68c3c86d97c3a95079f81b2c7f4bf35a
diff --git a/misc/kdeutils2/files/patch-portable.cpp b/misc/kdeutils2/files/patch-portable.cpp
new file mode 100644
index 000000000000..d6746dc1c282
--- /dev/null
+++ b/misc/kdeutils2/files/patch-portable.cpp
@@ -0,0 +1,20 @@
+--- klaptopdaemon/portable.cpp- Thu Jun 28 00:08:02 2001
++++ klaptopdaemon/portable.cpp Thu Jun 28 00:08:22 2001
+@@ -453,7 +453,7 @@
+ if (ret == -1)
+ return 0;
+
+- return (info.ai_batt_time != 0xffff);
++ return (info.ai_batt_time != -1);
+ }
+
+ //
+@@ -638,7 +638,7 @@
+
+ p.powered = info.ai_acline;
+ p.percentage = (info.ai_batt_life==255 ? 100 : info.ai_batt_life);
+- p.time = (info.ai_batt_time != 0xffff ? info.ai_batt_time/60 : -1);
++ p.time = (info.ai_batt_time != -1 ? info.ai_batt_time/60 : -1);
+ return(p);
+
+ bad:
diff --git a/misc/kdeutils2/pkg-plist b/misc/kdeutils2/pkg-plist
index 451d3587f1ef..a26fa72c3a97 100644
--- a/misc/kdeutils2/pkg-plist
+++ b/misc/kdeutils2/pkg-plist
@@ -251,7 +251,6 @@ share/services/arkpart.desktop
@dirrm share/icons/locolor
@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/32x32/apps
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/doc/HTML/en/kpm
@dirrm share/doc/HTML/en/knotes
@dirrm share/doc/HTML/en/klprfax
@@ -308,7 +307,6 @@ share/services/arkpart.desktop
@dirrm share/apps/ark/icons/hicolor
@dirrm share/apps/ark/icons
@dirrm share/apps/ark
-@dirrm share/apps
@dirrm share/applnk/Utilities
@dirrm share/applnk/System
@dirrm share/applnk/Settings/PowerControl
@@ -316,4 +314,3 @@ share/services/arkpart.desktop
@dirrm share/applnk/Settings
@dirrm share/applnk/Editors
@dirrm share/applnk
-@dirrm lib/kde2
diff --git a/misc/kdeutils3/Makefile b/misc/kdeutils3/Makefile
index 42d7e7fffe93..d1ab1df6523f 100644
--- a/misc/kdeutils3/Makefile
+++ b/misc/kdeutils3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeutils
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,11 +14,33 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+
.include <bsd.port.mk>
diff --git a/misc/kdeutils3/distinfo b/misc/kdeutils3/distinfo
index 562818721e98..2a396fa164aa 100644
--- a/misc/kdeutils3/distinfo
+++ b/misc/kdeutils3/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeutils-2.2.1.tar.bz2) = a511f6be6949d5b1c2f943f3f9ce27a5
+MD5 (KDE/kdeutils-2.2.2.tar.bz2) = 68c3c86d97c3a95079f81b2c7f4bf35a
diff --git a/misc/kdeutils3/files/patch-portable.cpp b/misc/kdeutils3/files/patch-portable.cpp
new file mode 100644
index 000000000000..d6746dc1c282
--- /dev/null
+++ b/misc/kdeutils3/files/patch-portable.cpp
@@ -0,0 +1,20 @@
+--- klaptopdaemon/portable.cpp- Thu Jun 28 00:08:02 2001
++++ klaptopdaemon/portable.cpp Thu Jun 28 00:08:22 2001
+@@ -453,7 +453,7 @@
+ if (ret == -1)
+ return 0;
+
+- return (info.ai_batt_time != 0xffff);
++ return (info.ai_batt_time != -1);
+ }
+
+ //
+@@ -638,7 +638,7 @@
+
+ p.powered = info.ai_acline;
+ p.percentage = (info.ai_batt_life==255 ? 100 : info.ai_batt_life);
+- p.time = (info.ai_batt_time != 0xffff ? info.ai_batt_time/60 : -1);
++ p.time = (info.ai_batt_time != -1 ? info.ai_batt_time/60 : -1);
+ return(p);
+
+ bad:
diff --git a/misc/kdeutils3/pkg-plist b/misc/kdeutils3/pkg-plist
index 451d3587f1ef..a26fa72c3a97 100644
--- a/misc/kdeutils3/pkg-plist
+++ b/misc/kdeutils3/pkg-plist
@@ -251,7 +251,6 @@ share/services/arkpart.desktop
@dirrm share/icons/locolor
@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/32x32/apps
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/doc/HTML/en/kpm
@dirrm share/doc/HTML/en/knotes
@dirrm share/doc/HTML/en/klprfax
@@ -308,7 +307,6 @@ share/services/arkpart.desktop
@dirrm share/apps/ark/icons/hicolor
@dirrm share/apps/ark/icons
@dirrm share/apps/ark
-@dirrm share/apps
@dirrm share/applnk/Utilities
@dirrm share/applnk/System
@dirrm share/applnk/Settings/PowerControl
@@ -316,4 +314,3 @@ share/services/arkpart.desktop
@dirrm share/applnk/Settings
@dirrm share/applnk/Editors
@dirrm share/applnk
-@dirrm lib/kde2
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index 42d7e7fffe93..d1ab1df6523f 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeutils
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,11 +14,33 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+
.include <bsd.port.mk>
diff --git a/misc/kdeutils4/distinfo b/misc/kdeutils4/distinfo
index 562818721e98..2a396fa164aa 100644
--- a/misc/kdeutils4/distinfo
+++ b/misc/kdeutils4/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeutils-2.2.1.tar.bz2) = a511f6be6949d5b1c2f943f3f9ce27a5
+MD5 (KDE/kdeutils-2.2.2.tar.bz2) = 68c3c86d97c3a95079f81b2c7f4bf35a
diff --git a/misc/kdeutils4/files/patch-portable.cpp b/misc/kdeutils4/files/patch-portable.cpp
new file mode 100644
index 000000000000..d6746dc1c282
--- /dev/null
+++ b/misc/kdeutils4/files/patch-portable.cpp
@@ -0,0 +1,20 @@
+--- klaptopdaemon/portable.cpp- Thu Jun 28 00:08:02 2001
++++ klaptopdaemon/portable.cpp Thu Jun 28 00:08:22 2001
+@@ -453,7 +453,7 @@
+ if (ret == -1)
+ return 0;
+
+- return (info.ai_batt_time != 0xffff);
++ return (info.ai_batt_time != -1);
+ }
+
+ //
+@@ -638,7 +638,7 @@
+
+ p.powered = info.ai_acline;
+ p.percentage = (info.ai_batt_life==255 ? 100 : info.ai_batt_life);
+- p.time = (info.ai_batt_time != 0xffff ? info.ai_batt_time/60 : -1);
++ p.time = (info.ai_batt_time != -1 ? info.ai_batt_time/60 : -1);
+ return(p);
+
+ bad:
diff --git a/misc/kdeutils4/pkg-plist b/misc/kdeutils4/pkg-plist
index 451d3587f1ef..a26fa72c3a97 100644
--- a/misc/kdeutils4/pkg-plist
+++ b/misc/kdeutils4/pkg-plist
@@ -251,7 +251,6 @@ share/services/arkpart.desktop
@dirrm share/icons/locolor
@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/32x32/apps
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/doc/HTML/en/kpm
@dirrm share/doc/HTML/en/knotes
@dirrm share/doc/HTML/en/klprfax
@@ -308,7 +307,6 @@ share/services/arkpart.desktop
@dirrm share/apps/ark/icons/hicolor
@dirrm share/apps/ark/icons
@dirrm share/apps/ark
-@dirrm share/apps
@dirrm share/applnk/Utilities
@dirrm share/applnk/System
@dirrm share/applnk/Settings/PowerControl
@@ -316,4 +314,3 @@ share/services/arkpart.desktop
@dirrm share/applnk/Settings
@dirrm share/applnk/Editors
@dirrm share/applnk
-@dirrm lib/kde2