aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/audacious/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/audacious/Makefile')
-rw-r--r--multimedia/audacious/Makefile44
1 files changed, 41 insertions, 3 deletions
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index f9606ab33752..9da96c1565ee 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -7,12 +7,13 @@
PORTNAME= audacious
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://audacious-media-player.org/release/
DISTNAME= audacious-${PORTVERSION}
EXTRACT_SUFX=.tgz
-MAINTAINER= redchrom@mail.ru
+MAINTAINER= redchrom@gmail.com
COMMENT= A media player based on BMP and XMMS
LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
@@ -30,8 +31,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
INPUT_PLUGINS="${INPUT_PLUGINS}" \
OUTPUT_PLUGINS="${OUTPUT_PLUGINS}" \
VISUALIZATION_PLUGINS="${VISUALIZATION_PLUGINS}"
+
MAN1= audacious.1
+PORTDOCS= README AUTHORS ChangeLog NEWS FAQ
+
INPUT_PLUGINS= cdaudio,mpg123,wav,tonegen,wma,console
OUTPUT_PLUGINS= OSS,disk_writer,crossfade
VISUALIZATION_PLUGINS= blur_scope
@@ -39,14 +43,16 @@ VISUALIZATION_PLUGINS= blur_scope
OPTIONS= VORBIS "Enable Ogg Vorbis input" on \
FLAC "Enable flac input" on \
ESOUND "Enable Esound output" off \
+ VISUAL "Enable libvisual plugin" off \
ID3V2 "Enable id3v2 editing" off \
- SIMD "build with x86 SIMD(3DNow!/MMX) instructions support" on \
+ SIMD "Build with x86 SIMD(3DNow!/MMX) instructions support" on \
SDL "Enable SDL support" off \
+ GNOME "Build with gnomevfs/gconf support" off
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 503000
-IGNORE= requires include/tgmath.h, which isn't available until FreeBSD 5.3
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Plugins_Input_wma_iir.h
.endif
.if !defined(WITHOUT_VORBIS)
@@ -81,6 +87,14 @@ CONFIGURE_ARGS+= --disable-esd
PLIST_SUB+= ESDPLUGIN:="@comment "
.endif
+.if defined(WITH_VISUAL)
+PLIST_SUB+= LIBVISUAL:=""
+VISUALIZATION_PLUGINS+= libvisual-proxy
+LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
+.else
+PLIST_SUB+= LIBVISUAL:="@comment "
+.endif
+
.if defined(WITH_ID3V2)
LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
.endif
@@ -97,6 +111,11 @@ CONFIGURE_ARGS+= --enable-simd
USE_SDL= sdl
.endif
+.if defined(WITH_GNOME)
+USE_GNOME+= gconf2 gnomevfs2
+CONFIGURE_ARGS+= --enable-gnome-vfs --enable-gconf
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
@@ -105,5 +124,24 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(WITH_GNOME)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You have installed audacious with gconf support."
+ @${ECHO_MSG} "ALL PRESETS will be storing in the gconf database."
+ @${ECHO_MSG} ""
+.endif
+.if defined(WITH_VISUAL)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You have installed audacious with libvisual support."
+ @${ECHO_MSG} "If you want to be able to access any visualizations,"
+ @${ECHO_MSG} "you must install the graphics/libvisual-plugins port."
+ @${ECHO_MSG} ""
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in README AUTHORS ChangeLog NEWS FAQ
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.post.mk>