aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/avifile/files/patch-ab
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/avifile/files/patch-ab')
-rw-r--r--multimedia/avifile/files/patch-ab89
1 files changed, 9 insertions, 80 deletions
diff --git a/multimedia/avifile/files/patch-ab b/multimedia/avifile/files/patch-ab
index e90a06661eba..6079eb3293b3 100644
--- a/multimedia/avifile/files/patch-ab
+++ b/multimedia/avifile/files/patch-ab
@@ -1,82 +1,11 @@
---- lib/avifile/AviWrite.cpp.orig Mon Sep 11 15:40:31 2000
-+++ lib/avifile/AviWrite.cpp Wed Sep 13 20:52:55 2000
-@@ -19,7 +19,11 @@
- try
- {
- m_status=0;
-+#ifdef O_LARGEFILE
- m_fd=open(name, O_WRONLY | O_CREAT | O_TRUNC | O_LARGEFILE, mask);
-+#else
-+ m_fd=open(name, O_WRONLY | O_CREAT | O_TRUNC, mask);
-+#endif
- if(m_fd==-1)
- throw FATAL("Can't open file for writing");
+--- xmps-avi-plugin/Makefile.in.orig Fri Oct 6 13:05:55 2000
++++ xmps-avi-plugin/Makefile.in Fri Oct 6 13:06:22 2000
+@@ -1,6 +1,6 @@
+-LIBS = -lstdc++ -L../lib -L@libdir@ -laviplay -lpthread @XMPS_LIBS@
++LIBS = -lstdc++ -L../lib -L@libdir@ -laviplay -lpthread @XMPS_LIBS@ @SDL_LIBS@
-@@ -203,7 +207,11 @@
- }
- long long AviWriteFile::FileSize()
- {
-+#ifdef __Linux__
- return lseek64(m_fd, 0, SEEK_CUR);
-+#else
-+ return lseek(m_fd, 0, SEEK_CUR);
-+#endif
- }
+-INCLUDES = -I. -I../include -I@includedir@/avifile @XMPS_CFLAGS@
++INCLUDES = -I. -I../include -I@includedir@/avifile @XMPS_CFLAGS@ @SDL_CFLAGS@
- AviWriteStream::AviWriteStream
---- lib/videocodec/Module.h.orig Sat Sep 9 14:24:49 2000
-+++ lib/videocodec/Module.h Wed Sep 13 20:20:25 2000
-@@ -4,6 +4,10 @@
- #include <videoencoder.h>
- #include <list>
- #include <string>
-+#ifdef __FreeBSD__
-+#include <sys/time.h>
-+#endif
-+
- using namespace std;
-
- class VideoCodecControl;
---- player/renderer.cpp.orig Mon Sep 11 08:38:07 2000
-+++ player/renderer.cpp Fri Sep 15 20:22:55 2000
-@@ -11,6 +11,7 @@
- #ifdef __FreeBSD__
- #include <machine/param.h>
- #include <sys/types.h>
-+#include <unistd.h>
- #endif
- #include <sys/ipc.h>
- #include <sys/shm.h>
---- lib/aviplay/aviutil.cpp.orig Sat Sep 16 13:49:08 2000
-+++ lib/aviplay/aviutil.cpp Sat Sep 16 13:54:06 2000
-@@ -28,16 +28,18 @@
- }
- CPU_Freq::CPU_Freq()
- {
-- FILE *f = fopen ("/proc/cpuinfo", "r");
- char line[200];
- char model[200]="unknown";
- char flags[500]="";
- char *s,*value;
-
-+#ifdef __FreeBSD__
-+ freq=old_freq();
-+ cerr<<freq/1000.<<" MHz processor detected"<<endl;
-+#else
-+ FILE *f = fopen ("/proc/cpuinfo", "r");
-+
- freq=-1;
--// freq=old_freq();
--// cerr<<freq/1000.<<" MHz processor detected"<<endl;
--// return;
- if (!f)
- {
- printf("Can't open /proc/cpuinfo for reading\n");
-@@ -86,6 +88,7 @@
- }
- #endif
- fclose(f);
-+#endif
- }
-
- CPU_Freq freq;
+ all: avi_configure.o avi_codec.o
+ $(CC) -shared avi_configure.o avi_codec.o $(LIBS) -o libavi.so