aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/clutter-gst/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/clutter-gst/Makefile')
-rw-r--r--multimedia/clutter-gst/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/multimedia/clutter-gst/Makefile b/multimedia/clutter-gst/Makefile
index e280fbad67fa..d50c72ca0218 100644
--- a/multimedia/clutter-gst/Makefile
+++ b/multimedia/clutter-gst/Makefile
@@ -11,21 +11,23 @@ MASTER_SITES= http://source.clutter-project.org/sources/${PORTNAME}/${PORTVERSIO
MAINTAINER= gnome@FreeBSD.org
COMMENT= Clutter GStreamer integration
-BROKEN= Fails to compile
-
LIB_DEPENDS= clutter-glx-1.0:${PORTSDIR}/graphics/clutter
-USE_BZIP2= yes
-USE_AUTOTOOLS= libtool
-USES= pathfix gmake pkgconfig
-USE_GNOME= ltverhack gnomeprefix
+USES= gmake libtool pathfix pkgconfig tar:bzip2
+GNU_CONFIGURE= yes
+USE_GNOME= gnomeprefix
USE_GSTREAMER= yes
USE_GL= gl
USE_XORG= xp x11
USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-silent-rules
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+INSTALL_TARGET= install-strip
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/clutter-gst/Makefile.in
-NO_STAGE= yes
.include <bsd.port.mk>